Ryan Marsaw wrote:
Hello.

While building PulseAudio with the latest Glibc-2.27 I get the following error:

[...]

In file included from pulsecore/shm.c:48:0:
./pulsecore/memfd-wrappers.h:36:19: error: static declaration of 'memfd_create' follows non-static declaration
  static inline int memfd_create(const char *name, unsigned int flags) {
                    ^~~~~~~~~~~~
In file included from /usr/include/bits/mman-linux.h:115:0,
                  from /usr/include/bits/mman.h:45,
                  from /usr/include/sys/mman.h:41,
                  from pulsecore/shm.c:37:
/usr/include/bits/mman-shared.h:46:5: note: previous declaration of 'memfd_create' was here
  int memfd_create (const char *__name, unsigned int __flags) __THROW;
      ^~~~~~~~~~~~
make[3]: *** [Makefile:8008: pulsecore/libpulsecommon_11.1_la-shm.lo] Error 1

[...]

I've included a patch that fixes the issue.
Reference:  https://patchwork.openembedded.org/patch/147648/

The patch seems like a little overkill for us. I haven't tested it but I think

sed -i '/int memfd_create/,+2 d' src/pulsecore/memfd-wrappers.h

will work until a new version of pulseaudio is released. Can you check for us?

  -- Bruce
--
http://lists.linuxfromscratch.org/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to