On 03/06/2018 10:43 PM, Ken Moffat wrote:
On Tue, Mar 06, 2018 at 10:26:44PM +0100, Tim Tassonis wrote:
Hi all

While trying to upgrade rsvg to 2.42.3, I got stuck at rsvg now requiring
cairo 1.15.4. After checking the cairo website, I found that the latest
snapshot is 1.15.10, from 2017-12-07:

https://www.cairographics.org/news/cairo-1.15.10/


Quoting https://www.cairographics.org/download/ :

|Snapshots
|
|We may from time to time create a snapshot of the current state of
|cairo. These snapshots do not guarantee API stability as the code is
|still in an experimental state. Again, you'll want both cairo and
|pixman packages from that directory.

So I suggest that we do not update rsvg until suitable stable cairo
(and pixman) versions are released (presumably, cairo-1.16).


Ok, that sound reasonable to me. However, I got a bit adventurous and did the upgrade in my system. So far, it seems that gtk3 and poppler have no problem and the API changes are backwards-compatible. I was also able to rebuild cairomm 1.12.2 over cairo 1.15.10, but as I am not as far as inkscape, it is only a compile test.

I will leave the tickets open in that case until cairo 1.16 is released and won't check-in my book changes.

Bye
Tim

--
http://lists.linuxfromscratch.org/listinfo/blfs-dev
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to