I have been struggling to make kdesu work as it is meant to, and was wondering 
if anyone has managed to get it to work.

I have done a lot of research on the net and there are numerous people who 
have had, and currently have issues with it, but no solution has worked for 

When you alt+f2 and type in kdesu systemsettings you get the expected password 
prompt for root user, then nothing happens.

Try kdesu dolphin and again nothing happens.

I am running a SYSTEMD system, and kdesud is running.

One solution that worked for people running debian,ubuntu and redhat was to 
install system alternatives and to create a kdesurc file and adding the command 
for sudo instead.  I have installed system alternatives in the hope that it 
may work.  It doesn't.  All you get is a blank box and no option to create the 
elevated user as per their instructions.

I have tested with a newly created account and it shows exactly the same 

I know I can just open a terminal and su to root normally, but some things 
need the gui version of su.

They have managed to lock KDE down so that root can not login even after you 
have changed the kdmrc to allow it.  You get a password incorrect.  I did a 
nasty sort of a work around to make X run as root and was able to access kde 
after invoking startx on the command line.  I then proceeded to use kdepasswd 
and entered the password and still it just refuses to login.

I know the risks of running a gui as root, but I am not a novice on linux/unix 

Not that I want to change many things through the gui, but things like kwallet 
do need to be tweaked via the gui.

It would be nice to have a tool work as it is meant to.


FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to