While there is a certain elegance to the names, I'd have to vote against those. It's not immediately obvious from the names trim/trimmed which one is inplace and which isn't. Further, in the matter of lower_cased/to_lower_case, if you guess wrong, the other one isn't nearby in an alphabetic listing of functions.
-- Truth, James Curran www.NovelTheory.com (Personal) www.NJTheater.com (Professional) www.aurora-inc.com (Day job) "Thorsten Ottosen" <[EMAIL PROTECTED]> wrote in message 020101c28db0$d6b56d90$76c3a8c0@nesottolap">news:020101c28db0$d6b56d90$76c3a8c0@nesottolap... > Perhaps one could use these names then: > > Seq trimmed(...); > void trim(...); > > Seq trim( const Seq& Input, const std::locale& Loc=std::locale() ) > > Seq& trim_in( Seq& Input, const std::locale& Loc=std::locale() ) > > and > > Seq lower_cased(...); > void to_lower_case(...); _______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost