----- Original Message -----
From: "Paul Mensonides" <[EMAIL PROTECTED]>

> Vesa, I hack this up so it works on all compilers and then add it to the
> CVS.  The main problem is that the implementation relies on expansion
order.
> That is another name for "VC and Metrowerks bugs."  I don't see why they
> can't be worked around though.

Vesa, I can get it to work on VC and Metrowerks if I alter the semantics
slightly.  Namely by doing this:

#define IS_ZERO(x) IS_ZERO_I( CHECK x () )
// ...

#define CHECK() 1

The semantic change is that 'x' must not be a function-like macro.  What do
you think?

Paul Mensonides

_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Reply via email to