From: "Peter Dimov" <[EMAIL PROTECTED]> > I'm thinking of renaming make_shared(weak_ptr), as the current similarity > with make_pair is undesirable. The best replacement I can come up with is > get_shared_ptr. I.e. instead of > > if(shared_ptr<X> px = make_shared(wp)) > { > } > > the pattern will look like > > if(shared_ptr<X> px = get_shared_ptr(wp)) > { > } > > Comments? Suggestions?
The convention to name make_X an object generator is pretty usual. It is also a standard boost convention: http://www.boost.org/more/generic_programming.html#object_generator Why do you want to change it? I think that get_shared_prt is confusing. Sted _______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost