"David B. Held" <[EMAIL PROTECTED]> wrote in message
b02kh4$7tp$[EMAIL PROTECTED]">news:b02kh4$7tp$[EMAIL PROTECTED]...
> "Philippe A. Bouchard" <[EMAIL PROTECTED]> wrote in message
> b02f0c$o1d$[EMAIL PROTECTED]">news:b02f0c$o1d$[EMAIL PROTECTED]...
> >
> >     It seems placement operator new (size_t, ...) would extend a lot
> > garbage collection possibilities.  Why don't we define a set of rules
for
> > each tag this overloaded placed operator would use:
>
> More logically, why don't you implement these yourself, and use
> your implementation to justify the interface you design?

Already did.  Cost / benefits are not good for operator new (size_t, os
[ownership]).

[...]

> Probably, "gc_ptr<>" might be a better name.

... or maybe:

shifted_ptr<int> = new (so) int();
displaced_ptr<int> = ...;
...



Philippe A. Bouchard




_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Reply via email to