> > The only place where you will see usage of the name > smart_ptr is somewhere > > deep in library code: > > > > typedef smart_ptr <...> GlobalMemoryHandler; > > > > After that you will use non-confusing name GlobalMemoryHandler. > > It may work out that way in this case - but why not make the name > non-confusing in the first place?
It's not confusing to me. > You appear here to concede that it *is* confusing. No. Imeant that *even* it is confusing for *you*, you still will see it only in one place. > We are talking about smart_ptr and a potential smart_resource > concept - not > GloalMemoryHandler - that was just an example of where the > naming becomes > particularly confusing - whether it is buried deep in library > code or not. This is an example of most wide IMO usage of smart_ptr framework: 1. you define custom policy 2. typedef your own type with correct name 3. Enjoy both correct name and flexible framework > I still have yet to hear why you do not like the idea of putting these > concepts in their appropriate order? I keep repeating that I do not see a difference in concepts. IOW IMO there is only one concept: resource management that is impleemented in framework named "smart_ptr" Regards, Gennadiy. _______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost