Daniel Frey <[EMAIL PROTECTED]> writes: > When looking at the current: > > class X : boost::addable< X > > { > X& operator+=( const X& ); > }; > > I wonder if addable is a good name. I thought that the classes are > named by the operator that is provided by the user and that they add > the operators that are based on it. Like here: > > class Y : boost::less_than_comparable< Y > > { > friend bool operator<( const Y&, const Y& ); > }; > > That given, the new class should be called 'addable', the current > class should probably be called 'add_assignable' or something like > that. But that would break the interface :(( Thoughts, anyone?
If anything, I think it's less_than_comparable which should change. -- Dave Abrahams Boost Consulting www.boost-consulting.com _______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost