graydon hoare wrote: > an inter-thread pipe might also be referred to as a synchronization > channel, if you want to avoid confusion about names (pipes being a > particular OS object). > > -graydon
Synchronization channel sounds good except that stream names are too long. synchronization_channel channel; // good // too long? synchronization_channel_istream in(channel); synchronization_channel_ostream out(channel); -- Alexander Nasonov Remove minus and all between minus and at from my e-mail for timely response _______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost