Hi All,
When changing a database definition in KeyBase, it is possible to
make the definition and data in the database inaccessible.
This happens if you introduce an error into the definitions file.
(Similar happens when creating a database, but you just can't
access the definition, obviously as there's no data).
An example of this is if you put a double quote into a help
message.
I was allowed to change the definition, but when re-entering the
database got:-
Error in KeyList definition file: <database name>, line <line
number
Work around for the double quote, use perhaps single quote or
round brackets instead.
Work around to try and correct the error.
Take a copy of the definition and database, (.cdb), file to
another directory.
I then copied the definitions file to a third directory to work
on it separately--after changing it I moved it back over writing
the original, I felt happier doing that than changing it in
place.
Enter the definitions file, (second copy), using KeyWord, you
will have to <space>x for the "All files" option, else it will
say the file doesn't exist.
Find the offending line and change, (example replace double
quotes you put in with single quotes--KeyBase uses double quotes
so don't take out the ones it entered).
Then move that changed definition copy back replacing the broken
one.
You should then be able to enter the database again.
Regards,
Steve.
----------------------------------------------------------
"seek ye first the kingdom of God, and his righteousness;"
(Matthew 6:33 AV)
----------------------------------------------------------
___
Replies to this message will go directly to the sender.
If your reply would be useful to the list, please send a
copy to the list as well.
To leave the BrailleNote list, send a blank message to
[EMAIL PROTECTED]
To view the list archives or change your preferences, visit
http://list.humanware.com/mailman/listinfo/braillenote