On Thu, Sep 10, 2026, at 17:11, Nicolai Buchwitz wrote:
>> diff --git a/net/packet/Kconfig b/net/packet/Kconfig
>> index 2997382d597c..00fda9e08cb0 100644
>> --- a/net/packet/Kconfig
>> +++ b/net/packet/Kconfig
>> @@ -5,6 +5,7 @@
>>
>> config PACKET
>> tristate "Packet socket"
>> + depends on IPV4
>
> depends on IPV4 || !INET
>
> Otherwise this would break existing configs with INET=n. The same
> applies to other affected options that currently permit INET=n.
Since that's a lot of symbols that all need the same dependency,
maybe we could have an intermediate symbol for it:
config IPV4_IF_INET # or any better name you can think of
def_bool IPV4 || !INET
Similarly, everything that currently has 'depends on INET && IPV4'
could be simplified to just 'depends on IPV4', and the leftover
'depends on INET && IPV6' from the days of modular IPV6 can now
become 'depends on IPV4'. We only needed to list both in the past
to deal with the IPV6=m case.
Arnd