Revision: 42430
          http://brlcad.svn.sourceforge.net/brlcad/?rev=42430&view=rev
Author:   brlcad
Date:     2011-01-19 07:47:49 +0000 (Wed, 19 Jan 2011)

Log Message:
-----------
rename db_get_version() to simply db_version().  there's no need for the getter 
name convention (inconsistent with api), especially when there's no putter.

Modified Paths:
--------------
    brlcad/trunk/include/raytrace.h
    brlcad/trunk/src/librt/db5_scan.c
    brlcad/trunk/src/librt/db_open.c

Modified: brlcad/trunk/include/raytrace.h
===================================================================
--- brlcad/trunk/include/raytrace.h     2011-01-19 05:10:13 UTC (rev 42429)
+++ brlcad/trunk/include/raytrace.h     2011-01-19 07:47:49 UTC (rev 42430)
@@ -3033,8 +3033,6 @@
                     const struct db5_raw_internal *rip,
                     off_t laddr,
                     genptr_t client_data));
-RT_EXPORT BU_EXTERN(int db_get_version,
-                   (struct db_i *dbip));
 RT_EXPORT BU_EXTERN(int db5_scan,
                    (struct db_i *dbip,
                     void (*handler)(struct db_i *,
@@ -3043,6 +3041,11 @@
                                     genptr_t client_data),
                     genptr_t client_data));
 
+/**
+ * obtain the database version for a given database instance
+ */
+RT_EXPORT BU_EXTERN(int db_version, (struct db_i *dbip));
+
 /* db5_comb.c */
 RT_EXPORT BU_EXTERN(int rt_comb_import5, (struct rt_db_internal *ip, const 
struct bu_external *ep, const mat_t mat, const struct db_i *dbip, struct 
resource *resp));
 

Modified: brlcad/trunk/src/librt/db5_scan.c
===================================================================
--- brlcad/trunk/src/librt/db5_scan.c   2011-01-19 05:10:13 UTC (rev 42429)
+++ brlcad/trunk/src/librt/db5_scan.c   2011-01-19 07:47:49 UTC (rev 42430)
@@ -441,7 +441,7 @@
 
 
 int
-db_get_version(struct db_i *dbip)
+db_version(struct db_i *dbip)
 {
     unsigned char header[8];
 
@@ -457,7 +457,7 @@
 
     rewind(dbip->dbi_fp);
     if (fread(header, sizeof(header), 1, dbip->dbi_fp) != 1) {
-       bu_log("db_get_version ERROR, file (%s) too short to be BRL-CAD 
database\n", dbip->dbi_filename);
+       bu_log("ERROR: file (%s) too short to be a BRL-CAD database\n", 
dbip->dbi_filename ? dbip->dbi_filename : "unknown");
        return -1;
     }
 

Modified: brlcad/trunk/src/librt/db_open.c
===================================================================
--- brlcad/trunk/src/librt/db_open.c    2011-01-19 05:10:13 UTC (rev 42429)
+++ brlcad/trunk/src/librt/db_open.c    2011-01-19 07:47:49 UTC (rev 42430)
@@ -207,7 +207,7 @@
     dbip->dbi_magic = DBI_MAGIC;               /* Now it's valid */
 
     /* determine version */
-    dbip->dbi_version = db_get_version(dbip);
+    dbip->dbi_version = db_version(dbip);
 
     if (RT_G_DEBUG & DEBUG_DB) {
        bu_log("db_open(%s) dbip=x%x version=%d\n", dbip->dbi_filename, dbip, 
dbip->dbi_version);


This was sent by the SourceForge.net collaborative development platform, the 
world's largest Open Source development site.

------------------------------------------------------------------------------
Protect Your Site and Customers from Malware Attacks
Learn about various malware tactics and how to avoid them. Understand 
malware threats, the impact they can have on your business, and how you 
can protect your company and customers by using code signing.
http://p.sf.net/sfu/oracle-sfdevnl
_______________________________________________
BRL-CAD Source Commits mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/brlcad-commits

Reply via email to