On Sep 13, 2013, at 9:02 PM, Tom Browder wrote:
> Maybe the whole API should be named bu_arg... in line with TCLAP terminology.
>
> So 'bu_opt_parse*' would be 'bu_arg_parse*'...
Oh, definitely! Either all bu_opt_* or all bu_opt_* .. I didn't (yet) see that.
Relevant is a section I added to HACKING a little while back (after a similar
discussion) about naming conventions to help move our APIs towards consistency:
Public API (global) function names are in lowercase with underscores
to separate words. Most functions within the core libraries are named
with the following convention: [library]_[group]_[action]
bu_vls_strcat()
bn_mat_transpose()
Naming exceptions are allowed where the API intentionally mirrors some
other familiar programming construct (e.g., bu_malloc()+bu_free()),
but care should otherwise be taken to be as consistent as possible
within a file and across a library's API.
Most of the core libs already follow that pattern pretty well, except probably
for librt. There are several chunks that probably belong in their own library
(like the db_*() and nmg_*() functions to name two).
Cheers!
Sean
------------------------------------------------------------------------------
LIMITED TIME SALE - Full Year of Microsoft Training For Just $49.99!
1,500+ hours of tutorials including VisualStudio 2012, Windows 8, SharePoint
2013, SQL 2012, MVC 4, more. BEST VALUE: New Multi-Library Power Pack includes
Mobile, Cloud, Java, and UX Design. Lowest price ever! Ends 9/22/13.
http://pubads.g.doubleclick.net/gampad/clk?id=64545871&iu=/4140/ostg.clktrk
_______________________________________________
BRL-CAD Developer mailing list
brlcad-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/brlcad-devel