Eric Blake wrote:
> According to Jim Meyering on 1/17/2010 1:03 AM:
>> Thanks!
>> That would fix it, but please retain the 0/1 semantics, in case
>> we ever want to use USE_XATTR in a C (as opposed to cpp) expression.
>>
>> # Map yes,no to 1,0.
>> AC_DEFINE_UNQUOTED([USE_XATTR],
>> [`test $use_xattr = yes && echo 1 || echo 0`],
>> [Define if you want extended attribute support.])
>
> OK, committed with that change.
Thank you.
I see you shortened it slightly, too:
... [`test $use_xattr != yes; echo $?`],
IMHO, that's slightly less readable than the above.
I hesitate to quibble too much (it's ok to leave it), since this is .m4
after all, but we should try to keep things accessible, when convenient.