Dear Henri,

Henri Raben via Bug reports for ddrescue, data recovery tool. wrote:
I wanted to use following command on a 2TB disk, because it was taking
to much time for pass 5, so tried to use the part of the disk with
--cpass=1 first, using hexadecimal numbers to define the bytes to be
read. The error message from ddrescue is also given. What am I doing
wrong? I couldn't find an example in the official documentation.

sudo ddrescue -f -d -n -N --reopen-on-error
--input-position=0x1CD042E000 --size=0x00AC2000 --skip-size=1024,8192
--cpass=1  /dev/sda /dev/sdd ~/Desktop/mapfile
ddrescue: Numerical argument out of limits.

The problem is that the skip sizes are too small. They must be at least 64 KiB. If you use, for example, sectors instead of bytes it works:

$ ddrescue -f -n -N --reopen-on-error --input-position=0x1CD042E000 --size=0x00AC2000 --skip-size=1024s,8192s --cpass=1 /dev/zero /dev/null
GNU ddrescue 1.26-pre1
Press Ctrl-C to interrupt
     ipos:  123764 MB, non-trimmed:        0 B,  current rate:   6553 kB/s
     opos:  123764 MB, non-scraped:        0 B,  average rate:   5640 kB/s
non-tried:        0 B,  bad-sector:        0 B,    error rate:       0 B/s
  rescued:   11280 kB,   bad areas:        0,        run time:          1s
pct rescued:  100.00%, read errors:        0,  remaining time:          0s
                              time since last successful read:         n/a
Copying non-tried blocks... Pass 1 (forwards)


  • Hexadecimal input Bug reports for ddrescue, data recovery tool.
    • Re: Hexadecimal input Antonio Diaz Diaz

Reply via email to