Hello, sorry if this is not properly a bug but I could not find any other user 
help lists or channels for ddrescue.

I was trying to do a block level backup of an old (2016) IDE drive, using dd in 
conjunction with a Unitek Y-3322 USB 3.0 To IDE/ + SATA Adapter. But dd would 
consistently freeze up at a point 20GB through reading the drive.

I switched over to ddrescue, but I'm getting the same result. At the 20GB 
point, ddrescue seems to freeze and will not respond to Control-C. And it stays 
frozen until I turn off the adapter, at which point it quits. I tried the -d 
and -T30 commands but get the same result.

This is the command I am using:

ddrescue -v -T30 -r3 -d /dev/disk/by-id/usb-DW_CDW08_A0JA-B003J0A_20221206-0\:0 
WMAV40536610.img backup.logfile

Not saying ddrescue is necessarily broke, but just wasn't sure how to move 
forward. Here is the information for my system:

christopher@theoden ~$ neofetch --stdout
OS: Guix System x86_64 
Host: OptiPlex 9020 00 
Kernel: 5.15.86-gnu 
Uptime: 2 days, 3 hours, 41 mins 
Packages: 93 (guix-system), 182 (guix-user) 
Shell: bash 5.1.8 
Resolution: 1920x1080 
Theme: Adwaita [GTK2/3] 
Icons: Adwaita [GTK2/3] 
Terminal: .gnome-terminal 
CPU: Intel i5-4570 (4) @ 3.600GHz 
GPU: Intel HD Graphics 
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM 
Memory: 3408MiB / 7867MiB 

christopher@theoden ~$ ddrescue --version
GNU ddrescue 1.27
Copyright (C) 2023 Antonio Diaz Diaz.
License GPLv2+: GNU GPL version 2 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com
馃寪 http://gem.librehacker.com

讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓

Reply via email to