Hi Niksa,

Thanks for your interest in GNU Chess, and for reporting about your
experience with it.

Unfortunately, I cannot reproduce the problem you describe. I have tried
the first command and I think it works fine. I have tried with XBoard
versions 4.9.1, 4.8.0 and 4.5.2, on two different O.S. After starting the
program, I chose Mode - Machine Match, and GNU Chess starts playing against

Certainly, the way GNU Chess reads commands on its standard input has
changed since v6.2.4, since it now uses a mechanism based on readline.

Could you give more information for troubleshooting your problem?

- log file adapter.log - you can enable it setting Log = true in
- config.status and config.log
- Does it happen with older versions of XBoard?
- Does it happen with other options for XBoard? For instance:
    xboard -fcp 'gnuchess --xboard' -scp 'gnuchess --xboard -fd <dirf> -sd
    xboard -fcp 'gnuchess --xboard'
- Which operating system are you using?

Antonio Ceballos

On Tue, Aug 8, 2017 at 7:28 AM, niksa <ni...@jurinovic.com> wrote:

> Hello,
> unlike gnuchess-6.2.4, the 6.2.5 version is not working with xboard-4.9.1,
> regardless of how it was invoked:
> # xboard -fcp "gnuchess --xboard" -scp "gnuchess --xboard"
> or
> # xboard -fUCI -fcp "gnuchess" -sUCI -scp "gnuchess"
> None of these two commands is working. The xboard screen appears and
> everything looks fine, but when the game starts, gnuchess responds with
> only one move and then hangs forever. This happens regardless of whether
> the opening book is enabled (set to true) or disabled (set to false). This
> didn't happen in gnuchess-6.2.4 that was working fine and without any
> problem.
> It is interesting however that version 6.2.5 works correctly with
> eboard-1.1.1.
> Is there any way to fix this?
> Regards,
> Niksa Jurinovic
> ni...@jurinovic.com
> _______________________________________________
> Bug-gnu-chess mailing list
> Bug-gnu-chess@gnu.org
> https://lists.gnu.org/mailman/listinfo/bug-gnu-chess
Bug-gnu-chess mailing list

Reply via email to