I wrote:
> If you see "options" as a generalization of "style" and "custom", then
> the systematic name should be 'quotearg_n_options_mem'. But then the
> functions which return their result in a buffer or freshly allocated
> should better be named
> 
>   quotearg_options_buffer      instead of  quotearg_buffer
>   quotearg_alloc_options       instead of  quotearg_alloc
>   quotearg_alloc_options_mem   instead of  quotearg_alloc_mem

Correction: The naming scheme is

  quotearg<return_convention><customizations><nul_handling>

where
    <return_convention> is either '' (for slot 0) or
                           '_n' (for slot n) or '_buffer' or '_alloc',
    <customizations>    is either '' or '_style' or '_custom' or
                           '_options',
    <nul_handling>      is either '' or '_mem'.

The proposed renamings should therefore be

  quotearg_buffer_options      instead of  quotearg_buffer
  quotearg_alloc_options       instead of  quotearg_alloc
  quotearg_alloc_options_mem   instead of  quotearg_alloc_mem

Bruno


Reply via email to