Bengt,

Sorry you had to debug that!

Bengt Richter 写道:
…then I get the desired output above. The difference is apparently util-linux 2.32.1 vs the newer 2.34, where the newer one understands
more field names for -o ...

[…]

Hope somebody can update it.
I think I found the updated version at
https://mirrors.edge.kernel.org/pub/linux/utils/util-linux/v2.34/util-linux-2.34.tar.xz

Guix's util-linux package was already updated to 2.34 in June (commit ac3842ef on core-updates), and it will be available when core-updates is merged into master. That should be very soon now. I'm closing this bug for that reason.

Updates of core Guix packages like these take a while to trickle down to users because ‘everything’ depends on them, and when they change ‘everything’ needs to be rebuilt, so we need to ‘batch’ these changes somehow to avoid rebuilding the world ever two days. Search for ‘staging’ and ‘core-updates’ in the manual. Unfortunately, core-updates in particular always takes longer to fix up and merge than expected.

Until that happens, you can define and install your own updated util-linux.

 (define-public util-linux/latest
   (package
     (inherit util-linux)
     (name "util-linux")
     (version "2.34")
     (source …))) ; updated URL

This is similar to what we already do for security updates in Guix.

Kind regards,

T G-R

Attachment: signature.asc
Description: PGP signature

Reply via email to