Diego Nicola Barbato <dnbarb...@posteo.de> writes:

> Hello Danny,
> Danny Milosavljevic <dan...@scratchpost.org> writes:
>> Hmm, how is that solved with other distributions?  Is "mount" suid root 
>> there?
> Indeed, in Debian both mount and umount are suid root:
>   $ stat -c "%a %U:%G %n" /bin/*mount
>   4755 root:root /bin/fusermount
>   4755 root:root /bin/mount
>   4755 root:root /bin/umount

I've tried adding "mount" and "umount" to `setuid-programs' in my
operating-system config:

--8<---------------cut here---------------start------------->8---
(setuid-programs (cons*                                       
                  #~(string-append #$util-linux "/bin/mount") 
                  #~(string-append #$util-linux "/bin/umount")
--8<---------------cut here---------------end--------------->8---

Mounting as an unprivileged user now works as expected (even the fancy
9p stuff).  Is there any rationale for not adding "mount" and "umount"
to `%setuid-programs' by default?



Reply via email to