I have reported a problem before when compiling a shared library
that depends on a static library.
See http://lists.gnu.org/archive/html/libtool/2005-06/msg00170.html
AFAIK, this problem has not been solved yet.

In any case, I "solved" this problem by specifying AC_DISABLE_SHARED.
However, my own library not only depends on a static library
but also on some other libtool libraries (not configured
with AC_DISABLE_SHARED) and that also produces incorrect results.

In particular, if you configure with AC_DISABLE_SHARED
and have an application "main" that (also) depends on some other
yet uninstalled libtool library then
the application will be linked against the .so version of
the library, but libtool will not create a .libs/main or .libs/lt-main
and the installed binary will refer to the uninstalled libtool
library rather than the installed libtool library.

To reproduce, untar the attached tar file and do

./autogen.sh && ./configure && make

Please advise on how to solve this conundrum.

skimo

Attachment: static-shared-test.tar.gz
Description: application/gunzip

_______________________________________________
Bug-libtool mailing list
Bug-libtool@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-libtool

Reply via email to