On Sun, Oct 14, 2001 at 09:27:26AM +0200, [EMAIL PROTECTED] wrote:
> I think m4_shipout_int is broken:
> [[snip]]
> and in fact, I'm also tempted by replacing it with something based
> on ntoa/numb_obstack as can be found in modules/m4.c. I guess there
> would be some loss of performance, but then, if you consider it's
> too expansive, anyway I would really like to see some m4_shipout_bigint
> somewhere: I already use it in some of my modules, and it results in
> a lot of code duplication. That would garantee some common flavor to
> all these macros.
>
> ?
Sounds good to me. shipout_int is not a heavily used function, so a small
loss in efficiency is a good trade off IMHO.
Cheers,
Gary.
--
())_. Gary V. Vaughan gary@(oranda.demon.co.uk|gnu.org)
( '/ Research Scientist http://www.oranda.demon.co.uk ,_())____
/ )= GNU Hacker http://www.gnu.org/software/libtool \' `&
`(_~)_ Tech' Author http://sources.redhat.com/autobook =`---d__/
_______________________________________________
Bug-m4 mailing list
[EMAIL PROTECTED]
http://mail.gnu.org/mailman/listinfo/bug-m4