Issue #2554 has been updated by ftigeot.

Description updated
Status changed from New to Resolved
% Done changed from 0 to 100

Your patch seems fine and has been pushed today.

Thanks for the fix!

----------------------------------------
Bug #2554: panic: chn_wrfeed(pcm0:play:2:dsp0.2): amt 4096 > source size 0, 
flags 0x0
http://bugs.dragonflybsd.org/issues/2554#change-11577

* Author: fgudin
* Status: Resolved
* Priority: Low
* Assignee: 
* Category: 
* Target version: 
----------------------------------------
Hello,
I've been suffering from this for quite some time (couldn't pinpoint the exact 
moment it appeared): while playing an .avi with mplayer, the machine would dump 
and reboot (dump and all will be uploading to leaf in a moment). This is a 
small box (VIA CPU) where everything is done in software (no DRM, etc.): I 
suspect that for some reason mplayer doesn't keep up filling data to the sound 
driver buffer, and at the wrong time, the kernel attempts to feed the hw 
channel, and boom.
The attached patch seems to cure (I forgot it during my update to the 3.4 
branch, and this morning it stroke back again). However, I'm neither certain my 
analysis is correct, nor that's the proper fix. Could anybody glance at it and 
provide advice, please ?

Thank you,
-- 
Francis



-- 
You have received this notification because you have either subscribed to it, 
or are involved in it.
To change your notification preferences, please click here: 
http://bugs.dragonflybsd.org/my/account

Reply via email to