Issue #3197 has been updated by tse.

File upgrade added

Hiya,

I realize this is quite a simple script, and possibly misses useful features 
(?). Originally posted to @users, but mailing list line-wraping didn't keep the 
script fully intact, so copy/paste/test wouldn't of worked

Also, the response on DragonFly Digest encouraged me re-post it here

I've tested it on new installs of 4.8, 5.2, and 5.4, and with installs 
previously upgraded with `make src-create/src-create-shallow`

It takes this: 
------ 
> cd /usr 
> make src-create 
> ... 
> make buildworld 
> make buildkernel 
> ... 
> make upgrade 
------

To this: 
------ 
> /usr/upgrade 
Upgrading DragonFly BSD

For more information see: 
`man build` `man config` 
/usr/src/README /usr/src/UPDATING 
http://www.dragonflybsd.org/docs/handbook/

It is possible to run this script without root privileges 
Usage: upgrade [configuration] 
Configuration is "X86_64_GENERIC"

Latest releases: 
[1] DragonFly_RELEASE_5_6 
[2] DragonFly_RELEASE_5_4 
[3] DragonFly_RELEASE_5_2 
[4] DragonFly_RELEASE_5_0 
[5] DragonFly_RELEASE_4_8

Select [1-5]: 
------

Note: I thankfully just did some retesting, and 'git fetch --depth=1' made git 
think HEAD was diverged since it didn't have the history to recognize even a 
single new commit. I've changed the script to do 'git checkout -B RELEASE 
origin/RELEASE' which should fix the issue, but I will retest DragonFly 4.8 on 
Monday, since sometimes those flags are not back-compatible

----------------------------------------
Bug #3197: DragonFly upgrades
http://bugs.dragonflybsd.org/issues/3197#change-13752

* Author: tse
* Status: New
* Priority: Normal
* Assignee: 
* Category: Feature request
* Target version: 
----------------------------------------
Hiya,

I realize this is quite a simple script, and possibly misses useful features 
(?). Originally posted to @users, but mailing list line-wraping didn't keep the 
script fully intact, so copy/paste/test wouldn't of worked

Also, the response on DragonFly Digest encouraged me re-post it here

I've tested it on new installs of 4.8, 5.2, and 5.4, and with installs 
previously upgraded with `make src-create/src-create-shallow`

It takes this:
------
> cd /usr
> make src-create
> ...
> make buildworld
> make buildkernel
> ...
> make upgrade
------

To this:
------
> /usr/upgrade
Upgrading DragonFly BSD

For more information see:
  `man build`      `man config`
  /usr/src/README  /usr/src/UPDATING
  http://www.dragonflybsd.org/docs/handbook/

It is possible to run this script without root privileges
Usage:  upgrade [configuration]
Configuration is "X86_64_GENERIC"

Latest releases:
  [1]  DragonFly_RELEASE_5_6
  [2]  DragonFly_RELEASE_5_4
  [3]  DragonFly_RELEASE_5_2
  [4]  DragonFly_RELEASE_5_0
  [5]  DragonFly_RELEASE_4_8

Select [1-5]:
------

---Files--------------------------------
upgrade (2.33 KB)
upgrade (2.35 KB)


-- 
You have received this notification because you have either subscribed to it, 
or are involved in it.
To change your notification preferences, please click here: 
http://bugs.dragonflybsd.org/my/account

Reply via email to