On Mon, Oct 17, 2016 at 01:31:36PM -0700, Mike Larkin wrote:
> On Sun, Oct 16, 2016 at 10:44:56PM -0400, Jim Faulkner wrote:
> > Hi folks, I own a (fairly old) Fit-PC2i.  It has a 32-bit only Intel Atom
> > dual core processor.  I ran the 5.9 i386 multiprocessor kernel without
> > problem.  However, the 6.0 MP kernel hangs at:
> > booting hd0a:/bsd: 7663236+2035096+189444+0+1085440 [72+518464+510159|
> > 
> > The 6.0 SP kernel works fine.  I patched the kernel today (Oct 16) and
> > rebuilt GENERIC.MP but the patched MP kernel still hangs.
> > 
> > Please see the attached dumps.tar.gz for dmesg, usbdevs, pcidump, and
> > acpidump output.  Let me know what other information I can provide.
> > 
> 
> Can you help by bisecting diffs? There wasn't much changed in that time
> frame that I could envision causing a hang here.
> 
> Thanks.
> 
> -ml
> 

PS, all you need to bisect is the kernel stuff (obviously). If it gets past
the point of hanging, you've found the offending commit.

I thought it may have been related to W^X, but you said 5.9 worked, and 
most of that was already in for 5.9. You could try to validate that part
by commenting out the "detect PAE" code in locore.s and see if it properly
falls back to no-PAE on your MP configuration.

-ml

Reply via email to