>Synopsis:      urtwm drops under heavy sustained load
>Category:      kernel
>Environment:
        System      : OpenBSD 6.6
        Details     : OpenBSD 6.6-current (GENERIC.MP) #439: Fri Nov  8 
14:00:31 MST 2019
                         
dera...@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP

        Architecture: OpenBSD.amd64
        Machine     : amd64
>Description:
        urtwm drops under heavy sustained load. Light sustained load and short 
bursts do not cause the drop. When the device drops, replugging it and 
restarting networking brings it back up fine. 
>How-To-Repeat:
        sysupgrade will sometimes cause the device to drop. I have not noticed 
any specific pattern of traffic to trigger it. 
>Fix:
        Replug the dongle and restart the network. The device will return to a 
working state. 


dmesg:
OpenBSD 6.6-current (GENERIC.MP) #439: Fri Nov  8 14:00:31 MST 2019
    dera...@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 5978714112 (5701MB)
avail mem = 5785182208 (5517MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 3.0 @ 0xdf266000 (27 entries)
bios0: vendor Insyde Corp. version "V1.00" date 03/20/2017
bios0: Acer Aspire A315-21
acpi0 at bios0: ACPI 5.0
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP MSDM BOOT HPET MCFG WDAT UEFI SSDT IVRS SSDT SSDT SSDT 
UEFI SPCR SSDT CRAT TPM2 FPDT ASF! WDRT VFCT SSDT APIC SSDT BGRT
acpi0: wakeup devices GPP1(S4) GPP4(S4) GFX0(S4) GFX1(S4) GFX2(S4) GFX3(S4) 
GFX4(S4) EHC1(S3) XHC0(S3)
acpitimer0 at acpi0: 3579545 Hz, 32 bits
acpihpet0 at acpi0: 14318180 Hz
acpimcfg0 at acpi0
acpimcfg0: addr 0xf8000000, bus 0-63
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 16 (boot processor)
cpu0: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G, 2994.74 MHz, 15-70-00
cpu0: 
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,MWAITX,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,XSAVEOPT
cpu0: 96KB 64b/line 3-way I-cache, 32KB 64b/line 8-way D-cache, 1MB 64b/line 
16-way L2 cache
cpu0: ITLB 48 4KB entries fully associative, 24 4MB entries fully associative
cpu0: DTLB 64 4KB entries fully associative, 64 4MB entries fully associative
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 8 var ranges, 88 fixed ranges
cpu0: apic clock running at 99MHz
cpu0: mwait min=64, max=64, IBE
cpu1 at mainbus0: apid 17 (application processor)
cpu1: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G, 2994.38 MHz, 15-70-00
cpu1: 
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,MMX,FXSR,SSE,SSE2,HTT,SSE3,PCLMUL,MWAIT,SSSE3,FMA3,CX16,SSE4.1,SSE4.2,MOVBE,POPCNT,AES,XSAVE,AVX,F16C,RDRAND,NXE,MMXX,FFXSR,PAGE1GB,RDTSCP,LONG,LAHF,CMPLEG,SVM,EAPICSP,AMCR8,ABM,SSE4A,MASSE,3DNOWP,OSVW,IBS,XOP,SKINIT,WDT,FMA4,TCE,NODEID,TBM,CPCTR,DBKP,PERFTSC,MWAITX,ITSC,FSGSBASE,BMI1,AVX2,SMEP,BMI2,XSAVEOPT
cpu1: 96KB 64b/line 3-way I-cache, 32KB 64b/line 8-way D-cache, 1MB 64b/line 
16-way L2 cache
cpu1: ITLB 48 4KB entries fully associative, 24 4MB entries fully associative
cpu1: DTLB 64 4KB entries fully associative, 64 4MB entries fully associative
cpu1: smt 1, core 0, package 0
ioapic0 at mainbus0: apid 4 pa 0xfec00000, version 21, 24 pins, remapped
ioapic1 at mainbus0: apid 5 pa 0xfec01000, version 21, 32 pins, remapped
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (GPP0)
acpiprt2 at acpi0: bus 2 (GPP1)
acpiprt3 at acpi0: bus 3 (GPP2)
acpiprt4 at acpi0: bus -1 (GPP3)
acpiprt5 at acpi0: bus -1 (GPP4)
acpiprt6 at acpi0: bus -1 (GFX0)
acpiprt7 at acpi0: bus -1 (GFX1)
acpiprt8 at acpi0: bus -1 (GFX2)
acpiprt9 at acpi0: bus -1 (GFX3)
acpiprt10 at acpi0: bus -1 (GFX4)
acpiec0 at acpi0
acpicpu0 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpicpu1 at acpi0: C2(0@400 io@0x414), C1(@1 halt!), PSS
acpipwrres0 at acpi0: WRST
acpipwrres1 at acpi0: P0U3, resource for XHC0
acpipwrres2 at acpi0: P3U3, resource for XHC0
acpipwrres3 at acpi0: P0U2, resource for EHC1
acpipwrres4 at acpi0: P3U2, resource for EHC1
acpipwrres5 at acpi0: P0SD, resource for SDIO
acpipwrres6 at acpi0: P3SD, resource for SDIO
acpipwrres7 at acpi0: P0ST, resource for SATA
acpipwrres8 at acpi0: P3ST, resource for SATA
acpitz0 at acpi0: critical temperature is 100 degC
acpibtn0 at acpi0: PWRB
acpipci0 at acpi0 PCI0: 0x00000010 0x00000011 0x00000000
acpicmos0 at acpi0
"PNP0C14" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpibtn1 at acpi0: SLPB
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT1 model "AP16M5J" serial 3742 type LION oem "PANASONIC"
acpibtn2 at acpi0: LID_
"AMD0030" at acpi0 not configured
"AMD0020" at acpi0 not configured
"AMD0020" at acpi0 not configured
"AMD0010" at acpi0 not configured
"SYNA7DB5" at acpi0 not configured
"AMD0010" at acpi0 not configured
"MSFT0101" at acpi0 not configured
acpivideo0 at acpi0: VGA_
acpivideo1 at acpi0: VGA_
acpivideo2 at acpi0: VGA_
cpu0: 2994 MHz: speeds: 3000 2700 2400 2100 1800 1400 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "AMD AMD64 15h Root Complex" rev 0x00
"AMD AMD64 15h IOMMU" rev 0x00 at pci0 dev 0 function 2 not configured
amdgpu0 at pci0 dev 1 function 0 "ATI Stoney Ridge" rev 0xda
drm0 at amdgpu0
amdgpu0: msi
azalia0 at pci0 dev 1 function 1 vendor "ATI", unknown product 0x15b3 rev 0x00: 
msi
azalia0: no supported codecs
pchb1 at pci0 dev 2 function 0 "AMD AMD64 15h Host" rev 0x00
ppb0 at pci0 dev 2 function 1 "AMD AMD64 15h PCIE" rev 0x00: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 2 function 2 "AMD AMD64 15h PCIE" rev 0x00: msi
pci2 at ppb1 bus 2
rtsx0 at pci2 dev 0 function 0 "Realtek RTL8411B Card Reader" rev 0x01: msi
sdmmc0 at rtsx0: 4-bit, dma
re0 at pci2 dev 0 function 1 "Realtek 8168" rev 0x12: RTL8411B (0x5c80), msi, 
address a8:1e:84:82:c3:0b
rgephy0 at re0 phy 7: RTL8251 PHY, rev. 0
ppb2 at pci0 dev 2 function 3 "AMD AMD64 15h PCIE" rev 0x00: msi
pci3 at ppb2 bus 3
vendor "Atheros", unknown product 0x0042 (class network subclass miscellaneous, 
rev 0x31) at pci3 dev 0 function 0 not configured
pchb2 at pci0 dev 3 function 0 "AMD AMD64 15h Host" rev 0x00
"AMD AMD64 15h PSP 2.0" rev 0x00 at pci0 dev 8 function 0 not configured
pchb3 at pci0 dev 9 function 0 "AMD AMD64 15h Host" rev 0x00
azalia1 at pci0 dev 9 function 2 "AMD AMD64 15h HD Audio" rev 0x00: apic 5 int 
22
azalia1: codecs: Realtek/0x0255
audio0 at azalia1
xhci0 at pci0 dev 16 function 0 "AMD FCH xHCI" rev 0x20: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "AMD xHCI root hub" rev 3.00/1.00 
addr 1
ahci0 at pci0 dev 17 function 0 "AMD FCH AHCI" rev 0x4b: apic 4 int 19, AHCI 1.3
ahci0: port 0: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, ST1000LM035-1RK1, ACM1> naa.5000c500a7f53af8
sd0: 953869MB, 512 bytes/sector, 1953525168 sectors
ehci0 at pci0 dev 18 function 0 "AMD FCH USB2" rev 0x49: apic 4 int 18
usb1 at ehci0: USB revision 2.0
uhub1 at usb1 configuration 1 interface 0 "AMD EHCI root hub" rev 2.00/1.00 
addr 1
"AMD FCH SMBus" rev 0x4b at pci0 dev 20 function 0 not configured
pcib0 at pci0 dev 20 function 3 "AMD FCH LPC" rev 0x11
pchb4 at pci0 dev 24 function 0 vendor "AMD", unknown product 0x15b0 rev 0x00
pchb5 at pci0 dev 24 function 1 vendor "AMD", unknown product 0x15b1 rev 0x00
pchb6 at pci0 dev 24 function 2 vendor "AMD", unknown product 0x15b2 rev 0x00
pchb7 at pci0 dev 24 function 3 vendor "AMD", unknown product 0x15b3 rev 0x00
pchb8 at pci0 dev 24 function 4 vendor "AMD", unknown product 0x15b4 rev 0x00
pchb9 at pci0 dev 24 function 5 vendor "AMD", unknown product 0x15b5 rev 0x00
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
pms0: Synaptics clickpad, firmware 8.2, 0x1e2a1 0x840300
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: SVM/RVI
efifb at mainbus0 not configured
uhub2 at uhub1 port 1 configuration 1 interface 0 "Advanced Micro Devices 
product 0x7900" rev 2.00/0.18 addr 2
uhub2: port 1, set config 0 at addr 3 failed
uhub2: device problem, disabling port 1
ugen0 at uhub2 port 3 "Lite-On Technology product 0x3015" rev 2.01/0.01 addr 3
uvideo0 at uhub2 port 4 configuration 1 interface 0 "KSVGA0500171401441LM06 VGA 
WebCam" rev 2.00/0.06 addr 4
video0 at uvideo0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (be97021614325285.a) swap on sd0b dump on sd0b
initializing kernel modesetting (STONEY 0x1002:0x98E4 0x1025:0x1192 0xDA).
amdgpu_irq_add_domain: stub
amdgpu0: 1366x768, 32bpp
wsdisplay0 at amdgpu0 mux 1: console (std, vt100 emulation), using wskbd0
wsdisplay0: screen 1-5 added (std, vt100 emulation)

usbdevs:
Controller /dev/usb0:
addr 01: 1022:0000 AMD, xHCI root hub
         super speed, self powered, config 1, rev 1.00
         driver: uhub0
Controller /dev/usb1:
addr 01: 1022:0000 AMD, EHCI root hub
         high speed, self powered, config 1, rev 1.00
         driver: uhub1
addr 02: 0438:7900 Advanced Micro Devices, product 0x7900
         high speed, self powered, config 1, rev 0.18
         driver: uhub2
addr 03: 04ca:3015 Lite-On Technology, product 0x3015
         full speed, self powered, config 1, rev 0.01
         driver: ugen0
addr 04: 0bda:5648 KSVGA0500171401441LM06, VGA WebCam
         high speed, power 500 mA, config 1, rev 0.06, iSerial 200901010001
         driver: uvideo0
addr 05: 7392:7811 Realtek, 802.11n WLAN Adapter
         high speed, power 500 mA, config 1, rev 2.00, iSerial 00e04c000001
         driver: urtwn0

Reply via email to