On Wed, Sep 09, 2026 at 06:45:13PM +0200, Alex Rnne Petersen wrote:
> On Wed, Sep 9, 2026, at 18:27, Nick Owens wrote:
> > On Wed, Sep 2, 2026 at 4:55???PM <[email protected]> wrote:
> >>
> >> >Synopsis:      Network daemons sporadically fail during boot in arm64 VM
> >> >Category:      system
> >> >Environment:
> >>         System      : OpenBSD 7.9
> >>         Details     : OpenBSD 7.9 (GENERIC.MP) #8: Fri Aug 21 13:35:08 MDT 
> >> 2026
> >>                          
> >> [email protected]:/usr/src/sys/arch/arm64/compile/GENERIC.MP
> >>
> >>         Architecture: OpenBSD.arm64
> >>         Machine     : arm64
> >> >Description:
> >>         We (Zig) recently acquired an AmpereOne A192-32X machine to 
> >> self-host
> >>         and cover all our arm64 CI needs. OpenBSD is of course one of the
> >>         platforms we would like to test on arm64. Unfortunately, we are 
> >> facing
> >>         an issue where, in the VM we created for OpenBSD, the basic network
> >>         daemons will sporadically fail during boot for no apparent reason.
> >>
> >>         The affected daemons are (at least) dhcpleased, ntpd, resolvd, and
> >>         slaacd. Sometimes only a subset will fail, sometimes all, sometimes
> >>         none. All I can tell is that they seem to be getting killed during 
> >> rc,
> >>         likely by the kernel. The only indication of this that I see is 
> >> "Killed"
> >>         messages in the console, but even these don't always appear when 
> >> the
> >>         issue happens. There also does not appear to be anything relevant 
> >> in any
> >>         /var/log file. When it happens, I can rcctl start the failed 
> >> daemons
> >>         from the console, and things appear fine from there.
> >
> > this sounds a bit like
> > https://marc.info/?l=openbsd-tech&m=178407511210176&w=2 - are you sure
> > swap is on, or is it off?
> 
> The symptoms described there do match my experience exactly, however, swap
> is definitely on and defined correctly in /etc/fstab. But as noted, it's a
> swap *file* rather than partition, so perhaps that matters?

Given the specific daemons you've listed, your swap file is probably not
active when those are started by rc.  Have a look at the ordering in /etc/rc.

Reply via email to