On 2018-03-06 15:59, Erik Joelsson wrote:
I don't think we can unify them, since topdir in the first section is
really TOPDIR (i.e. never the custom root), but found out differently
than normal. (It is possible that it could be renamed TOPDIR, but I
wanted to make it clear that it is not the "normal" value of TOPDIR).
When looking at this patch, I realized that topdir has a different
meaning depending on if you are in the HAS_SPEC conditional or not. In
the first section, topdir is always the open root dir, but in the else
section it is set to CUSTOM_ROOT if available. This is rather
confusing. Could we unify the value of this variable?
The second section has the meaning "TOPDIR or CUSTOM_ROOT", and is used
only for COMPARE_BUILD. Do you have any suggestion on a good name?
(TOPDIR_OR_CUSTOM_ROOT does not qualify as "good name", imho.)
On 2018-03-06 01:23, Magnus Ihse Bursie wrote:
This fix will enable patch files for COMPARE_BUILD to be hosted in a