More info on this... It seems to be an LLVM issue. Blowing everything away and rebuilding everything without LLVM fixes the issue. Too bad though, LLVM worked just fine on FreeBSD through 7.8.3.

It seems like a specific bug, though. Cabal would work some of the time, and I did manage to compile and run other programs.

I also did a little work with GDB to try and diagnose the issue. The crash seems to happen in a function called recent_activity, and it looks like a bad jump into a block of 0's. I'm afraid I don't know enough to continue with the diagnosis, though.


Unrelated, but I also noticed that checking the profile option the FreeBSD port now uses the --enable-executable-profiling option in addition to --enable-library-profiling, which builds cabal, happy, alex, and friends with profiling built in. Previously, the ports would just build with --enable-library-profiling, which is probably more in line with what users expect to have happen.

On 10/18/15 13:12, Eric McCorkle wrote:
Hello,

I just updated my Haskell installation in FreeBSD 11 to GHC 7.10 using
the ports tree.  I am now seeing segfaults from cabal whenever I try to
install anything, or even update the package list.

Curiously, port builds of Haskell packages seem to work just fine, which
leads me to believe the problem is in one of the dependencies as opposed
to cabal itself.

Also, I can manually compile and run simple programs.

I tried various settings (LLVM/no, profile on/off, dynamic on/off) to no
avail.

Has anyone else seen this?  Any advice on how to go about diagnosing the
problem?
_______________________________________________
FreeBSD-haskell mailing list
freebsd-hask...@haskell.org
http://mail.haskell.org/cgi-bin/mailman/listinfo/freebsd-haskell
_______________________________________________
cabal-devel mailing list
cabal-devel@haskell.org
http://mail.haskell.org/cgi-bin/mailman/listinfo/cabal-devel

Reply via email to