Hey rtgwork,

I believe you should use this syntax when naming fields:
name="[model]/[field]"

That's how Cake captures the data and store it in $this->data

I would recommend using HTML helper using: $html->hidden("cpu/
primaryhd", array("value" => $primaryhdAll))

If you really really prefer using your own naming convention, you can
always fall back to $_POST["primaryhd"] or $_GET["primaryhd"]

On Dec 26, 2:12 am, rtgwork <[EMAIL PROTECTED]> wrote:
> I have this code in my view:
>
> <form name="configurator" id="configurator">
>     <input type="hidden" name="cpu" value="<?php echo $cpuAll; ?>">
>     <input type="hidden" name="primaryhd" value="<?php echo
> $primaryhdAll; ?>">
>     <input type="hidden" name="secondaryhd" value="<?php echo
> $secondaryhdAll; ?>">
>     <input type="hidden" name="memory" value="<?php echo $memoryAll; ?>">
>
>     <input type="hidden" name="backup" value="<?php echo $backupAll; ?>">
>
>     <input type="hidden" name="os" value="<?php echo $osAll; ?>">
>     <input type="button" name="submit" value="submit" border=0
> onclick="new Ajax.Updater('updateDiv', 'mailer', {asynchronous:true,
> evalScripts:true, parameters:Form.serialize(this.form)})">
> </form>
>
> In my controller in function mailer(), I am using pr($this->data), but
> there is nothing showing.  Looks like the ajax call is not passing the
> serialized form.
>
> What is wrong with my code?
>
> Thanks.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Cake 
PHP" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/cake-php?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to