Hi Marco,

Although your problem is a bit different, another possible culprit is the .caret5_preferences file:

http://brainvis.wustl.edu/pipermail/caret-users/2006-November/000931.html

We're still struggling with this problem at University of Washington. Today I asked Veronica to try the attached script, which strips the recent files and directories from the caret preferences before launching caret. I'm curious whether it helps in your case, in case the .fonts.conf trick fails. Let us know what you find.

On 11/29/2006 11:19 AM, John Harwell wrote:
Marco,

Another user had a problem similar to this. I believe it has to do with the FreeType library which gets used to create text characters that are drawn on the volume slices to show the voxel and its stereotaxic coordinate.

See if there is a file in your home directory named ".fonts.conf" (note that the file begins with a period so use the command "ls -a" to see the file). If ".fonts.conf" exists, rename it, start Caret, and see if you can import a volume.

For more info: http://www.mail-archive.com/caret-users@brainvis.wustl.edu/msg00892.html

----------------------------------------------------------
John Harwell
[EMAIL PROTECTED]
314-362-3467

Department of Anatomy and Neurobiology
Washington University School of Medicine
660 S. Euclid Ave.    Box 8108
St. Louis, MO 63110   USA

On Nov 29, 2006, at 10:42 AM, marco tettamanti wrote:

Hi Donna and Hohn,
I am experiencing a severe problem with my caret installation in linux: whenever I try to import an Analyze Volume file, my entire X session immediately crashes, including all applications and I have to login in KDE from scratch. I couldn't tell whether the problem is limited to the Import function only, because the system crashes so badly that I thought it would be better to obtain some feedback from you before doing some debugging. But all the other display functions of caret that I have tried out (rendering surfaces, overlaying metric maps and so on) seem to work fine.

I first encountered the problem a few days ago. I completely ignore what could be the origin of the problem. I had used the same installation without any problems before, including the Import function. I have also tried to do a fresh install, of both versions 5.4 and 5.5, but the problem persists.

I did some updates of KDE and xorg recently, though, and I suspect that the problem may have arosen since then. All other applications run fine, though.

Also, I have installed the same .zip caret tar ball on another machine and there it runs fine...

This is the kernel of my machine:

Linux bll4 2.6.11-kanotix-11 #1 Sun May 29 22:32:10 CEST 2005 i686 GNU/Linux


Any help would be greatly appreciated!


Best,
Marco

--Marco Tettamanti, Ph.D.
San Raffaele Scientific Institute
Facoltà di Psicologia
Via Olgettina 58
I-20132 Milano, Italy
Tel. ++39-02-26434888
Fax ++39-02-26434892
Email: [EMAIL PROTECTED]
_______________________________________________
caret-users mailing list
caret-users@brainvis.wustl.edu
http://pulvinar.wustl.edu/mailman/listinfo/caret-users


_______________________________________________
caret-users mailing list
caret-users@brainvis.wustl.edu
http://pulvinar.wustl.edu/mailman/listinfo/caret-users



--
Donna L. Dierker
(Formerly Donna Hanlon; no change in marital status -- see 
http://home.att.net/~donna.hanlon for details.)

Attachment: caret_prefs_stripper.sh
Description: Bourne shell script

Reply via email to