Hi Mateus,

I replicated your probelm exactly with the roi.zip archive you uploaded. It contained only the flat coord and cut topo; have you tried using the fiducial coord with closed topo? It may not help, but it's worth a try.

Although the clusters using metric2 appear smaller in area than the metric1 clusters, the nodes within the metric2 clusters are denser, which probably is a factor. See the attached captures, shows the dense metric 2 clusters and the sparser metric 1 clusters, using drawing mode: Links (No Backside) on the D/C surface misc menu. The top two clusters are only a single tile wide, so I'm not surprised Caret would have trouble drawing a border around them. The two bottom ones also have places where they're only a tile wide, so maybe that's the problem. If so, and switching coord/topo combos fails, then I"m not sure what else to suggest.

Doing a very small amount of metric smoothing (Average neighbors, 1 iteration, strength 1.0) and reducing the threshold a tad would probably help (primarily just making the clusters larger), but I'm guessing this is something you'd be very hesitant to do.

On 01/25/2007 08:33 AM, Mateus Joffily wrote:
Hi Donna,

I restarted Caret and I created a new Spec file, including only the topology, flat coordinates, metric and surface shape files, and the problem persists. I did the following tests until now:

1) I tried the same operation, selecting only one of the clusters for which the program didn't draw borders before, but the program complains "No clusters were found".

2) I tried the same operation with another metric that has even smaller cluster, and the program draws the borders correctly.

3) I tried some other operations on the selected nodes (e.g. Assign metric column to selected nodes, and Statistical report), and the program works fine for every cluster. Only 'Create Borders Around Clusters' doesn't work.

I uploaded my new Spec file (roi.zip) with the two metrics included ('metric1': problematic one; and 'metric2': with smaller clusters that works fine). If you have any other idea about what can be the problem...

Thank you very much,

Donna Dierker wrote:

The only thing I can think to try is to restart Caret and repeat your selection of all nodes within threshold 1.0 to 50000.0. I can see from your capture that you did this and your green nodes include clusters for which it didn't draw borders. My only guess is that perhaps somehow the create borders is still acting on a previous nodes connected to node number 33651 selection, even though this radio button isn't selected (and the green nodes show select nodes was pressed with All nodes within threshold selected). Restarting simply removes any previous selections, if there is a bug lurking here.

Otherwise, my only other guess is that Caret has a minimum area for clusters, before it will generate a border around it, and the smaller ones fall below that threshold. I'm not aware of such a limit.

If you upload your spec file (including coord, topo, and metric), I can see if my luck is any better than yours:


On 01/24/2007 10:55 AM, Mateus Joffily wrote:


I am trying to use 'Surface Region of Interest' to create borders around metric clusters. The nodes on the surface are correctly selected, but when I select 'Create Borders Around Clusters' only one of the clusters is surrounded by a border. I have tried the same operation with other metric columns and the program seems to work fine. I don't know why, for this specific metric, some clusters are left out. I am attaching an image of caret windows. Any suggestion is well appreciated.




caret-users mailing list

caret-users mailing list

Donna L. Dierker
(Formerly Donna Hanlon; no change in marital status -- see 
http://home.att.net/~donna.hanlon for details.)

<<inline: metric2_small_but_dense.jpg>>

<<inline: metric1_skinny.jpg>>

Reply via email to