Hi.

I reply to myself.  It seems to be related with the maven overlay version. 
I changed the version to 5.0.4 and all is fine now.

Thanks

El lunes, 20 de marzo de 2017, 21:32:20 (UTC-4), Roannel Fernandez escribió:
>
> Hi folks:
>
> I'm using cas-overlay-template, v5.0.3.1 and the embedded Tomcat. I'm 
> trying to configure the JPA Service Registry, but allways I get the 
> following error:
>
> 2017-03-20 21:00:01,944 ERROR [org.springframework.boot.context.embedded.
> tomcat.TomcatStarter] - <Error starting Tomcat context. Exception: org.
> springframework.beans.factory.UnsatisfiedDependencyException. Message: 
> Error creating bean with name 'casLoggingConfiguration': Unsatisfied 
> dependency expressed through field 'ticketRegistrySupport'; nested 
> exception is org.springframework.beans.factory.
> UnsatisfiedDependencyException: Error creating bean with name 
> 'casCoreTicketsConfiguration': Unsatisfied dependency expressed through 
> field 'httpClient'; nested exception is org.springframework.beans.factory.
> UnsatisfiedDependencyException: Error creating bean with name 
> 'casCoreAuthenticationConfiguration': Unsatisfied dependency expressed 
> through field 'servicesManager'; nested exception is org.springframework.
> beans.factory.UnsatisfiedDependencyException: Error creating bean with 
> name 'servicesManager' defined in class path resource [org/apereo/cas/
> config/CasCoreServicesConfiguration.class]: Unsatisfied dependency 
> expressed through method 'servicesManager' parameter 0; nested exception 
> is org.springframework.beans.factory.BeanCreationException: Error 
> creating bean with name 'jpaServiceRegistryDao': Injection of persistence 
> dependencies failed; nested exception is org.springframework.beans.factory
> .BeanCreationException: Error creating bean with name 
> 'serviceEntityManagerFactory' defined in class path resource [org/apereo/
> cas/config/JpaServiceRegistryConfiguration.class]: Invocation of init 
> method failed; nested exception is javax.persistence.PersistenceException: 
> [PersistenceUnit: jpaServiceRegistryContext] Unable to build Hibernate 
> SessionFactory>
> 2017-03-20 21:00:02,130 WARN [org.springframework.boot.context.embedded.
> AnnotationConfigEmbeddedWebApplicationContext] - <Exception encountered 
> during context initialization - cancelling refresh attempt: org.
> springframework.context.ApplicationContextException: Unable to start 
> embedded container; nested exception is org.springframework.boot.context.
> embedded.EmbeddedServletContainerException: Unable to start embedded 
> Tomcat>
>
> My service configuration is as follow:
>
> #Service configuration
> cas.serviceRegistry.jpa.healthQuery=SELECT 1
> cas.serviceRegistry.jpa.url=jdbc:mysql://localhost:3306/casdb
> cas.serviceRegistry.jpa.dialect=org.hibernate.dialect.MySQL5Dialect
> cas.serviceRegistry.jpa.user=user
> cas.serviceRegistry.jpa.password=pass
> cas.serviceRegistry.jpa.driverClass=com.mysql.cj.jdbc.Driver
> cas.serviceRegistry.jpa.ddlAuto=update
>
> My dependencies are:
>
>     <dependencies>
>         <dependency>
>             <groupId>org.apereo.cas</groupId>
>             <artifactId>cas-server-webapp</artifactId>
>             <version>${cas.version}</version>
>             <type>war</type>
>             <scope>runtime</scope>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apereo.cas</groupId>
>             <artifactId>cas-server-support-jdbc</artifactId>
>             <version>${cas.version}</version>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apereo.cas</groupId>
>             <artifactId>cas-server-support-jpa-service-registry
> </artifactId>
>             <version>${cas.version}</version>
>         </dependency>
>         </dependencies>   
>
> Please, somebody help me.
>
> Thanks
>

-- 
- CAS gitter chatroom: https://gitter.im/apereo/cas
- CAS mailing list guidelines: https://apereo.github.io/cas/Mailing-Lists.html
- CAS documentation website: https://apereo.github.io/cas
- CAS project website: https://github.com/apereo/cas
--- 
You received this message because you are subscribed to the Google Groups "CAS 
Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/a/apereo.org/d/msgid/cas-user/762cff60-0a85-45cb-ace6-53b6c0deeb72%40apereo.org.

Reply via email to