I apologize in advance, I didn't realize that the jasig-cas-user list 
wasn't the current one because that's the list that showed up in my Google 
searches, and it appears to still be active based on others posting out 
there.

So I'm cross-posting to this list, which I guess is the current one?










Hi all,

This has been driving me nuts the last couple of days, so I decided to just 
reach out in case anyone had thoughts.

The long story is we used Apereo CAS up through version 4.x last year, then 
switched over to WSO2 per our SIS vendor's recommendation (Ellucian -- they 
developed CAS plugins for WSO2, and the promise of not having to maintain 
both CAS and Shibboleth servers was too great to pass up.) However, it's 
definitely not meeting our needs, so I'm in the process of switching us 
back to the regular Apereo CAS.

I'm using the maven overlay template, and things seem to be working ok so 
far, with the exception of the service registry (specifically, the JSON 
registry.) I'm running into two problems that I'm hoping someone can help 
out with.

1.) How in the world do you get CAS to not include the default Apereo and 
HTTPS/IMAPS service configuration when you package?
2.) It seems as if the ability to do an external file location for the 
service registry isn't functional on the latest version?

At this point I've googled my fingers to the bone on both issues, but 
haven't come up with the magical working combination. Based on threads like 
the following, it seems like things should just work, but none of the 
things suggested have:
https://groups.google.com/forum/#!topic/jasig-cas-user/UpflUgRKtT0
https://groups.google.com/forum/#!topic/jasig-cas-user/fukomW8Ayos
https://groups.google.com/a/apereo.org/forum/#!topic/cas-user/IXIrh-ZqzrY
https://apereo.github.io/cas/5.1.x/installation/JSON-Service-Management.html
(and several others)

I've verified that I've got the cas-server-support-json-
service-registry dependency added, and tried every which way to set the 
cas.serviceRegistry.config.location option (colon vs equals sign, file:, 
file://, no "file" at all, etc.) and still, it always ignores the external 
location that I've set (/etc/cas/services folder.) I've checked filesystem 
permissions (even set to 777 for a while,) and after each attempt would go 
through the regimen of:
- undeploy war
- ./build.sh clean
- ./build.sh package
- redeploy war

all to no avail, and with nothing in the catalina or CAS logs. Even if I 
set a totally bogus cas.serviceRegistry.config.location, it doesn't throw 
any errors/warnings/etc.

If I create a "src/main/resources/services" folder in the 
cas-overlay-template folder, and put a .json file in it, it gets picked up 
and dumped in the "classpath:/services" folder of the deployed application 
(/usr/share/tomcat/webapps/cas/WEB-INF/classes/services), as expected. 
Which I guess works (except for the fact that I don't want the two default 
.json services.) But I'd much rather have the .json files saved to that 
/etc/ folder if at all possible.

I'm curious if the problem is related to the 
cas-server-support-json-service-registry plugin? The reason I'm wondering 
that is because I tried to set up the cas-management webap, and it's doing 
the same thing -- instead of following my request to pull the services from 
the CAS classpath:/services location 
(file:/usr/share/tomcat/webapps/cas/WEB-INF/classes/services), it's pulling 
from its own WEB-INF/classes/services folder.

(Obviously, I'd rather have them pull from /etc/cas/services...or anywhere 
else...but barring that, I'd like for the management webapp to at least be 
functional.)

We're currently on version 5.2.2 2018-01-31T22:29Z 
<http://www.apereo.org/cas> on SLES 12 SP3, Tomcat 8.0.43, Java 8.

Thanks much!

Chris

-- 
- Website: https://apereo.github.io/cas
- Gitter Chatroom: https://gitter.im/apereo/cas
- List Guidelines: https://goo.gl/1VRrw7
- Contributions: https://goo.gl/mh7qDG
--- 
You received this message because you are subscribed to the Google Groups "CAS 
Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to cas-user+unsubscr...@apereo.org.
To view this discussion on the web visit 
https://groups.google.com/a/apereo.org/d/msgid/cas-user/bcc670ef-36b7-4248-860c-9dc3f40e6abd%40apereo.org.

Reply via email to