Hi,

To solve this problem, I choose CAS dependency to integrate in my
cas-manager by checking the spring version in apereo/cas gradle.build file
for matching the cas-manager version.

Mickaël

Le jeu. 30 juil. 2020 à 15:27, Jeremiah Garmatter <[email protected]> a
écrit :

> Follow-up:
>
> I've placed the absolute ordering tag within the ROOT application's
> web.xml file and I was able to get past the spring_web web-fragment error.
> However, once I did that, I received the same error for log4j,
> note-for-note. After looking within cas-management/WEB-INF/lib, I found
> dozens of repeated jar files. The same jar, but different versions. For
> example, spring-web-4.3.17.RELEASE.jar and spring-web-4.3.20.RELEASE.jar. I
> tried playing around with the versions maven uses to resolve dependencies
> with cas-management-overlay-5.3/pom.xml without luck. Currently, I receive
> the same error as posted yesterday with or without the <absolute-ordering/>
> tag inside ROOT/WEB-INF/web.xml. I even tried making a web.xml for the
> cas-management server in a misunderstood attempt at a solution.
>
> Has anyone seen this before?
>
> On Wednesday, July 29, 2020 at 4:15:01 PM UTC-4 Jeremiah Garmatter wrote:
>
>>
>> Hello,
>>
>> Recently, I've built a new(er) version of CAS for my university's SSO.
>> I am utilizing CAS maven overlay to build CAS 5.3 deployed through
>> tomcat. I recently decided to add the management webapp (v5.3) and after
>> adding it to tomcat's webapps directory, I received this error:
>>
>> 29-Jul-2020 16:08:00.669 SEVERE [localhost-startStop-1]
>> org.apache.catalina.core.ContainerBase.addChildInternal
>> ContainerBase.addChild: start:
>>         org.apache.catalina.LifecycleException: Failed to start component
>> [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/cas-management]]
>>                 at
>> org.apache.catalina.util.LifecycleBase.handleSubClassException(LifecycleBase.java:440)
>>                 at
>> org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:198)
>>                 at
>> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:743)
>>                 at
>> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:719)
>>                 at
>> org.apache.catalina.core.StandardHost.addChild(StandardHost.java:705)
>>                 at
>> org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1125)
>>                 at
>> org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1858)
>>                 at
>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
>>                 at
>> java.util.concurrent.FutureTask.run(FutureTask.java:266)
>>                 at
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
>>                 at
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
>>                 at java.lang.Thread.run(Thread.java:748)
>>         *Caused by: java.lang.IllegalArgumentException: More than one
>> fragment with the name [spring_web] was found. This is not legal with
>> relative ordering. See section 8.2.2 2c of the Servlet specification for
>> details. Consider using absolute ordering.*
>>                 at
>> org.apache.tomcat.util.descriptor.web.WebXml.orderWebFragments(WebXml.java:2203)
>>                 at
>> org.apache.tomcat.util.descriptor.web.WebXml.orderWebFragments(WebXml.java:2162)
>>                 at
>> org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1131)
>>                 at
>> org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:776)
>>                 at
>> org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:299)
>>                 at
>> org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:123)
>>                 at
>> org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5053)
>>                 at
>> org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
>>                 ... 10 more
>> 29-Jul-2020 16:08:00.669 SEVERE [localhost-startStop-1]
>> org.apache.catalina.startup.HostConfig.deployDirectory Error deploying web
>> application directory [/var/lib/tomcat/cas-management]
>>         java.lang.IllegalStateException: ContainerBase.addChild: start:
>> org.apache.catalina.LifecycleException: Failed to start component
>> [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/cas-management]]
>>                 at
>> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:747)
>>                 at
>> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:719)
>>                 at
>> org.apache.catalina.core.StandardHost.addChild(StandardHost.java:705)
>>                 at
>> org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1125)
>>                 at
>> org.apache.catalina.startup.HostConfig$DeployDirectory.run(HostConfig.java:1858)
>>                 at
>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
>>                 at
>> java.util.concurrent.FutureTask.run(FutureTask.java:266)
>>                 at
>> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
>>                 at
>> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
>>                 at java.lang.Thread.run(Thread.java:748)
>>
>> I looked up absolute ordering and placed <absolute-ordering/> into my
>> web.xml deployment right before the </web-app> line and still received
>> the error. I've tried cleaning Tomcat's work directory as well. I heard
>> that Tomcat may be using the cached data, but no luck there.
>>
>> Any ideas?
>>
> --
> - Website: https://apereo.github.io/cas
> - Gitter Chatroom: https://gitter.im/apereo/cas
> - List Guidelines: https://goo.gl/1VRrw7
> - Contributions: https://goo.gl/mh7qDG
> ---
> You received this message because you are subscribed to the Google Groups
> "CAS Community" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email protected].
> To view this discussion on the web visit
> https://groups.google.com/a/apereo.org/d/msgid/cas-user/38f822e9-258e-476e-8bfa-266ecb8dc16en%40apereo.org
> <https://groups.google.com/a/apereo.org/d/msgid/cas-user/38f822e9-258e-476e-8bfa-266ecb8dc16en%40apereo.org?utm_medium=email&utm_source=footer>
> .
>

-- 
- Website: https://apereo.github.io/cas
- Gitter Chatroom: https://gitter.im/apereo/cas
- List Guidelines: https://goo.gl/1VRrw7
- Contributions: https://goo.gl/mh7qDG
--- 
You received this message because you are subscribed to the Google Groups "CAS 
Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/a/apereo.org/d/msgid/cas-user/CAM2C0GwE2MTMs1g4vcNnR2jx0y8o1X2Yyus_3jKn12%3DYWpO8Ug%40mail.gmail.com.

Reply via email to