John, The underlaying OS should have no effect on how cas runs. Check your version of java against what is recommended for your version of cas (it may have changed with RHEL upgrade). If banner is failing authn, it is not getting the attributes (in particular UDC_IDENTIFIER). Attribute retrieval happens during a callback (banner -> cas). (Unless you are using SAML2.) The audit log should show what is happening / failing; otherwise, turn up logging in cas.
Upgrading major cas versions may involve changes to property names and service definitions (the class for the service). There will also be changes to key lengths for encryption / signing. Depending on your ticket store, this may require removing existing tickets during the deployment (cas will no longer be able to read them). If you can, set up a dev/test environment and run through the upgrade steps there. Ray P.S. With Modular we have this in our setenv.sh JDK_JAVA_OPTIONS="$JDK_JAVA_OPTIONS \ --add-modules java.se \ --add-exports java.base/jdk.internal.ref=ALL-UNNAMED \ --add-opens java.base/java.lang=ALL-UNNAMED \ --add-opens java.base/java.nio=ALL-UNNAMED \ --add-opens java.base/sun.nio.ch=ALL-UNNAMED \ --add-opens java.management/sun.management=ALL-UNNAMED \ --add-opens jdk.management/com.sun.management.internal=ALL-UNNAMED" ________________________________ From: [email protected] <[email protected]> on behalf of John Adams <[email protected]> Sent: July 8, 2026 08:50 To: CAS Community <[email protected]> Subject: [cas-user] Upgrading from CAS 6.1.5 to 7.x? You don't often get email from [email protected]. Learn why this is important<https://aka.ms/LearnAboutSenderIdentification> Hi, I've inherited an old CAS 6.1.5 clustered pair running on RHEL 7 that we've been trying to upgrade. It's been a bit of a journey. As RHEL 7 is out of support, the first thing we tried was upgrading the OS to RHEL 8 and seeing what CAS would do. As it turned out, it wasn't too difficult to get CAS "working"--catalina.out looks great--but we found that the only service vital to support was failing to authenticate. We weren't able to make that work. I'm not sure why. (For what it's worth, the service failing to authenticate is our legacy Banner system. When I try to connect, the UI tells me authentication failed.) After some false starts, my boss said, "Let's go to a higher version of CAS on a single node with a newer OS." Which makes sense, but I get the impression from the documentation that going from 6.x to 7.x is a major lift. I'm sure some of you have had to do that in the distant past. What was it like for you? Thanks, John A -- - Website: https://apereo.github.io/cas - List Guidelines: https://goo.gl/1VRrw7 - Contributions: https://goo.gl/mh7qDG --- You received this message because you are subscribed to the Google Groups "CAS Community" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]<mailto:[email protected]>. To view this discussion visit https://groups.google.com/a/apereo.org/d/msgid/cas-user/372ee92f-8bc1-427c-836e-0fb30a000d5dn%40apereo.org<https://groups.google.com/a/apereo.org/d/msgid/cas-user/372ee92f-8bc1-427c-836e-0fb30a000d5dn%40apereo.org?utm_medium=email&utm_source=footer>. -- - Website: https://apereo.github.io/cas - List Guidelines: https://goo.gl/1VRrw7 - Contributions: https://goo.gl/mh7qDG --- You received this message because you are subscribed to the Google Groups "CAS Community" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. To view this discussion visit https://groups.google.com/a/apereo.org/d/msgid/cas-user/YQBP288MB00818ADF34C0C2883898CF69CEFF2%40YQBP288MB0081.CANP288.PROD.OUTLOOK.COM.
