Hi guys, this may have been raised before but just in case,

The IWindsorContainer interface describes the following,
                /// <summary>
                /// Adds a concrete class and an interface
                /// as a component and specify the extended properties.
                /// Used by facilities, mostly.
                /// The key to obtain the component will be the FullName of the
type.
                /// </summary>
                /// <typeparam name="I"></typeparam>
                /// <typeparam name="T"></typeparam>
                /// <param name="extendedProperties"></param>
                IWindsorContainer AddComponentLifeStyle<I, T>(IDictionary
extendedProperties) where T : class;

The method name describes this as a method that has something to do
with adding component and specifying the LifeStyle. But the
description doesn't mention this at all (the LifeStyle part).


Next WindsorContainer which implements IWindsorContainer implements
this method as follows,
    public IWindsorContainer AddComponentLifeStyle<I, T>(IDictionary
extendedProperties) where T : class
    {
        Type t = typeof(T);
        AddComponentWithProperties(t.FullName, typeof(I), t,
extendedProperties);
        return this;
    }

As you can see the AddComponentLifeStyle method just calls
AddComponentWithProperties. Hence this AddComponentLifeStyle method
has nothing to do with LifeStyle.

To me the method should be called should be renamed to
AddComponentWithProperties. As things currently stand there is no
"AddComponentWithProperties<I, T>(IDictionary extendedProperties)"
implemented. I think that the method being named AddComponentLifeStyle
is a copy and paste mistake.

Cheers
Anthony

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Castle Project Development List" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/castle-project-devel?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to