On Wed, Nov 14, 2012 at 7:45 AM, Fernan Aguero <fernan.agu...@gmail.com>wrote:

> Hi,
> I'm having this issue with my catalyst app where the session table is
> not fully qualified in the generated SQL statement:


> The sessions table lives in my PostgreSQL database in a separate
> schema 'webapp'.
> So I would expect the statement to be:
> DELETE FROM webapp.sessions WHERE ( id = ? )
> I also have the table name fully qualified in the corresponding DBIC
> schema class (GUS/Webapp/Sessions.pm):

DBIC works well with schemas.

The first obvious question is permissions. Have you tried manually
connecting as the app user using pgsql and then selecting the table using
the fq name?

Pg requires grants on an object by object basis not like MySQL where you
can do something like grant all on *.db. You have to grant one by one to
the Catalyst DB user to the objects in the particular schema, unless of
course the user is the owner of the schema and in that case you don't even
need to fq the object names.

Also, if you are creating your Result classes with loader have you tried


Alejandro Imass
List: Catalyst@lists.scsys.co.uk
Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
Dev site: http://dev.catalyst.perl.org/

Reply via email to