I know this isn't strictly a Catalyst question, but it's preventing me
downloading Catalyst (or anything else) from CPAN onto my VirtualBox VMs.

I posted a bug report for the CPAN module 12 days ago but nothing has

I work a lot with Ubuntu VMs on a Windows host. Everything worked fine
until a month or so ago.

I've got Windows 7 at work and Windows 10 at home. The problem occurs with
any combination of Ubuntu 12.04, 14.04 or 16.04 on Windows 7 or Windows 10.

The problem doesn't occur with 14.04 on an Ubuntu 16.04 laptop as a host. A
Rackspace Ubuntu 16.04 server seems OK.

I've tried several different CPAN mirrors.

I can download and install CPAN modules manually (by clicking the
"Download" link on the web page.)

The problem is that 90% of the time, I get this sort of thing:

Running make install
  Delayed until after prerequisites
Running install for module 'Starman'
Running make for M/MI/MIYAGAWA/Starman-0.4014.tar.gz
Fetching with LWP:
Catching error: "read failed: Connection reset by peer at
/usr/local/share/perl/5.18.2/LWP/Protocol/http.pm line 465. at
/usr/local/share/perl/5.18.2/LWP/UserAgent.pm line 916.\cJ" at
/usr/share/perl/5.18/CPAN.pm line 392.
    CPAN::shell() called at /usr/share/perl/5.18/App/Cpan.pm line 338
    App::Cpan::_process_options('App::Cpan') called at
/usr/share/perl/5.18/App/Cpan.pm line 421
    App::Cpan::run('App::Cpan') called at /usr/bin/cpan line 12

That's the output from installing Module::Install::Catalyst. The place at
which is stops varies, it isn't always Starman. However, it's very rare for
the whole install to complete successfully.

The problem occurs with CPANplus and cpanm as well.

Does anybody have any ideas what's going on? Or how to troubleshoot why the
server is closing the connection?

All the best.


*Duncan Garland*
Perl Team Leader

The information contained in this message is for the intended addressee 
only and may contain confidential and/or privileged information. If you are 
not the intended addressee, please delete this message and notify the 
sender; do not copy or distribute this message or disclose its contents to 
anyone. Any views or opinions expressed in this message are those of the 
author and do not necessarily represent those of Motortrak Limited or of 
any of its associated companies. No reliance may be placed on this message 
without written confirmation from an authorised representative of the 

Registered in England 3098391 V.A.T. Registered No. 667463890
List: Catalyst@lists.scsys.co.uk
Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
Dev site: http://dev.catalyst.perl.org/

Reply via email to