Actually `umask` option was already there (ccache version 3.7.11) but
it worked correctly: umask 002 worked well, umask 511 didn't work.

Now it works incorrectly: umask 002 doesn't work, umask 511 works
well. Looks like a bug with bitmask operations.

On Wed, May 4, 2022 at 8:36 PM Aleksey Midenkov <> wrote:
> After the software upgrade I noticed my IDE cannot compile a project
> after it was built from the terminal. It turned out that build
> directory now contains objects with such strange permissions:
> -r--r--r--
> When I removed ccache from the compiling command it created normal rw
> files. My umask is 0002
> I suspected it is because of the new `umask` setting in ccache which
> works differently by default (which is a really bad design choice).
> `ccache -p` printed just an empty value for that setting. Setting it
> to 0002 and clearing it with `ccache -C` didn't help anything. So, how
> it works now and how to get it back to human-expected behaviour?
> ccache version 4.5.1
> --
> @midenok


ccache mailing list

Reply via email to