In your HQ GK config you have not specified the IP address to which the GK
will be bound, commented below in blue:

gatekeeper
 zone local HQ cisco.com         <<< NO IP specified here, router will pick
one (see below)
 no zone subnet HQ default enable
 zone subnet HQ 10.1.5.3/32 enable
 zone subnet HQ 10.1.5.2/32 enable
 zone subnet HQ 10.1.130.1/32 enable
 no shutdown
!

If you do not specify an IP on the "zone local" command the router will
pick a specific IP - I don't recall the exact rule offhand, but it may be
the highest numbered loopback, and if none the highest physical interface.
 That default method doesn't matter since you can (ie, should) manually
assign the specific IP you want to use and not worry about how the router
will pick if you don't.


*FIX -> Assign an IP for the GK to listen on:*

gatekeeper
 zone local HQ cisco.com *10.1.110.1  *      <<< specify the desired IP
here after the domain - you can optionally specify a port after the IP, but
if you don't it will default to1719 (and will be listed in show run with
port 1719), which is fine unless the question tells you otherwise

You should probably shut/no shut your gatekeeper after this change.  It may
even require you to remove the existing zone local HQ first.  To speed up
your BR2 gateway re-registering do a "no gateway" then gateway on that
side.  When I lab I always specific the GK IP even if not called out by the
question.  I typically use the loopback0 for GK and if using a CUBE I
typically will use the voice vlan SVI - but it doesn't matter unless the
question states what to use.



For reference, the other related commands commented below:

*! BR2 side*
interface Vlan130
 ip address 10.1.130.1 255.255.255.0
 h323-gateway voip interface      <<< specifies to use this interface to
source RAS
 h323-gateway voip id HQ ipaddr 10.1.5.1 1719   <<< register to zone "HQ"
at gatekeeper with IP 10.1.5.1 on port 1719
 h323-gateway voip h323-id BR2   <<< the local gateway's h323 identifier is
"BR2"
 h323-gateway voip tech-prefix 56   <<< tell the GK that my tech-prefix (to
get to me, BR2) is 56 (on the GK you will see tech prefix 56*)

^make sure the above BR2 commands are applied on the interface you want BR2
to source, and the IP called out on the HQ side is listed on the "zone
local"


*! HQ side*
interface GigabitEthernet0/0.110
 encapsulation dot1Q 110
 ip address 10.1.110.1 255.255.255.0
 ip helper-address 10.1.5.2
 h323-gateway voip interface   <<< use this interface to source RAS
messages (when talking TO another GK, not when you ARE the GK...when you
ARE the GK that is the zone local IP indicated above).  When setting up a
CUBE on the same router as the GK then this command will determine which IP
the "CUBE" registers to the "GK" with even though they are the same router.
 Both addresses can even be the same, i believe.
 h323-gateway voip bind srcaddr 10.1.110.1   <<< use this interface to
source h.225/h.245/rtp traffic.  If your question states something like
"the phone's IP address should not be know by the "cloud gatekeeper and
should only see media from IP w.x.y.z" then this command is used to pin
media (along with media flow through on the voip dial peer) to the desired
IP.  Otherwise, this IP needs to match on the CUCM side if the gateway is
using h323 to CUCM instead of mgcp.

^make sure the above HQ commands are applied on the interface you want the
HQ router to source for CUBE, they are unnecessary (and don't do anything)
for the GK process and are needed for cube (or if the gateway is h.323 then
the voip bind src is needed to match the configured IP in CUCM)


Hope this helps...

-Justin



On Mon, Oct 7, 2013 at 8:56 PM, Josh Petro <josh.pe...@gmail.com> wrote:

> Hi All,
> I have a strange issue I ran into on a lab recently. The BR2 gateway would
> not register to the HQ gatekeeper unless I changed the IP address from the
> 'voice' subnet IP to the 'data' subnet IP.
>
> The question said I could not configure the gatekeeper with Zone Prefixes,
> Aliases nor could I register any e.164 addresses with it. It also said I
> could only allow the CUCM and BR2 endpoints to register to it. That
> basically left me to use the Zone Subnet commands.
>
> Why would the BR2 gateway not register until I changed the command on the
> VLAN interface from this:
> interface Vlan130
>  ip address 10.1.130.1 255.255.255.0
>  h323-gateway voip interface
> * h323-gateway voip id HQ ipaddr 10.1.110.1 1719 G0/0.110 interface*
>  h323-gateway voip h323-id BR2
>  h323-gateway voip tech-prefix 56
>
> to this
>
> interface Vlan130
>  ip address 10.1.130.1 255.255.255.0
>  h323-gateway voip interface
> * h323-gateway voip id HQ ipaddr 10.1.5.1 1719 !gig0/0.5 interface*
>  h323-gateway voip h323-id BR2
>  h323-gateway voip tech-prefix 56
>
>
>
>
>
> Here's the config
>
> HQ
> interface GigabitEthernet0/0
>  no ip address
>  duplex auto
>  speed auto
>  media-type rj45
> !
> interface GigabitEthernet0/0.5
>  encapsulation dot1Q 5
>  ip address 10.1.5.1 255.255.255.0
> !
> interface GigabitEthernet0/0.10
>  encapsulation dot1Q 10
>  ip address 10.1.10.1 255.255.255.0
>  ip helper-address 10.1.5.2
> !
> interface GigabitEthernet0/0.110
>  encapsulation dot1Q 110
>  ip address 10.1.110.1 255.255.255.0
>  ip helper-address 10.1.5.2
>  h323-gateway voip interface
>  h323-gateway voip bind srcaddr 10.1.110.1
> !
> gatekeeper
>  zone local HQ cisco.com
>  no zone subnet HQ default enable
>  zone subnet HQ 10.1.5.3/32 enable
>  zone subnet HQ 10.1.5.2/32 enable
>  zone subnet HQ 10.1.130.1/32 enable
>  no shutdown
> !
> !
>
>
> BR2
> interface Vlan130
>  ip address 10.1.130.1 255.255.255.0
>  h323-gateway voip interface
>  h323-gateway voip id HQ ipaddr 10.1.5.1 1719
>  h323-gateway voip h323-id BR2
>  h323-gateway voip tech-prefix 56
> !
> dial-peer voice 855 voip
>  translation-profile outgoing SiteCode
>  destination-pattern 855....
>  session target ras
>  tech-prefix 55
>  dtmf-relay h245-alphanumeric
> !
> dial-peer voice 887 voip
>  translation-profile outgoing SiteCode
>  destination-pattern 887....
>  session target ras
>  tech-prefix 87
>  dtmf-relay h245-alphanumeric
> !
>
>
> _______________________________________________
> For more information regarding industry leading CCIE Lab training, please
> visit www.ipexpert.com
>
> Are you a CCNP or CCIE and looking for a job? Check out
> www.PlatinumPlacement.com
>
_______________________________________________
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Reply via email to