On 05/17/2018 01:57 PM, Frank Sauerburger wrote:
> Hi all,
> 
> I'm trying to install libvirt for xen on a brand new, minimal
> installation of CentOS 7.5.1804. After installing the OS, I did a 'yum
> update' and followed the basic how-tos at
> 
>     https://wiki.centos.org/HowTos/Xen/Xen4QuickStart
> 
> and
> 
>     https://wiki.centos.org/HowTos/Xen/Xen4QuickStart/Xen4Libvirt
> 
> From previous experience, I know that the above steps worked fine.
> However, now on CentOS 7.5, I am seeing the dependency resolution failing.
> 
> $ yum install libvirt libvirt-daemon-xen
> [ ... ]
> Error: Package: libvirt-daemon-xen-3.2.1-402.el7.x86_64 (centos-virt-xen-46)
>            Requires: libvirt-daemon-driver-nwfilter = 3.2.1-402.el7
>            Available:
> libvirt-daemon-driver-nwfilter-3.2.1-402.el7.x86_64 (centos-virt-xen-46)
>                libvirt-daemon-driver-nwfilter = 3.2.1-402.el7
>            Available: libvirt-daemon-driver-nwfilter-3.9.0-14.el7.x86_64
> (base)
>                libvirt-daemon-driver-nwfilter = 3.9.0-14.el7
>            Installing:
> libvirt-daemon-driver-nwfilter-3.9.0-14.el7_5.2.x86_64 (updates)
>                libvirt-daemon-driver-nwfilter = 3.9.0-14.el7_5.2
> Error: Package: libvirt-daemon-driver-libxl-3.2.1-402.el7.x86_64
> (centos-virt-xen-46)
>            Requires: libvirt-daemon = 3.2.1-402.el7
>            Available: libvirt-daemon-3.2.1-402.el7.x86_64
> (centos-virt-xen-46)
>                libvirt-daemon = 3.2.1-402.el7
>            Available: libvirt-daemon-3.9.0-14.el7.x86_64 (base)
>                libvirt-daemon = 3.9.0-14.el7
>            Installing: libvirt-daemon-3.9.0-14.el7_5.2.x86_64 (updates)
>                libvirt-daemon = 3.9.0-14.el7_5.2
> 
> [ ... similar errors ... ]
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
> 
> I've never seen an error like this before. As far as I read it,
> libvirt-daemon-xen wants version 3.2.1 of its dependencies. I've checked
> the repositories and it seems that in 'base' and 'updates' we have
> version 3.9.0 and in the 'virt' repo we have 3.2.1 of libvirt. Can I
> solve this issue on my end? Should I force yum to install the packages
> from the 'virt' repo?

Red Hat upgraded the libvirt provided in 7.5 from 3.2.0 to 3.9.0, but
they don't provide a Xen driver, which is the reason you are seeing the
dependency issue.

A 4.1.0 release of libvirt is currently in testing, along with other
updates to deal with CentOS 7.5 changes.  You also need to exclude the
seabios updates because HVM guests cannot boot using the new Red Hat
version.

The best workaround for now is probably to either set up
yum-plugin-priorities and set a high priority on the centos-virt-xen*
repo, or exclude=libvirt* seabios* in your base and updates repos.

-- 
Kevin Stange
Chief Technology Officer
Steadfast | Managed Infrastructure, Datacenter and Cloud Services
800 S Wells, Suite 190 | Chicago, IL 60607
312.602.2689 X203 | Fax: 312.602.2688
ke...@steadfast.net | www.steadfast.net
_______________________________________________
CentOS-virt mailing list
CentOS-virt@centos.org
https://lists.centos.org/mailman/listinfo/centos-virt

Reply via email to