On 03/06/18 09:34, Fred Smith wrote:
On Tue, Mar 06, 2018 at 04:12:58PM +0100, Fabian Arrotin wrote:
On 05/03/18 19:53, Fred Smith wrote:
Hi all!

I've finally been reduced to having to install Skype on my Linux box.
I resisted for years, but now ended up trying it.

and while the latest RPM installs just fine, it refuses to acknowledge
that I have a microphone!

In fact I have two: 1 in the USB web cam (it finds the cam), the second
in a Plantronics USB headset, which works fine but not with skype.
it is as if it doesn't exist.

So, when I connect to someone I can hear them, see them, and they can
see me, but I'm producing no sound output.

All the web hits I can find for nonfunctional microphone on the web
are for Ubuntu. GAH!

running ldd against the skypeforlinux binary results in a huge list
of shared libraries, including libasound (which is what the ubuntu
messages say is missing).

Anybody got a clue?

Thanks in advance!


I'm not a skype user myself, so haven't tried it, but as there are many
apps that are in FlatHub, and so directly accessible for CentOs 7 (that
comes with flatpak since 7.4.1708)

Have you tried with that one ?

No, but wouldn't it be the same binaries as MS distributes? (which is
what I have).

I posted a reply to my own message in which I noted that I had later
discovered that it works fine with my old analog mic/headset, but
the USB one may as well not be attached, as Skype acts as if it is
not even there.

Does USB microphone work with other applications?

Weird-but-frustrating, because my USB webcam works, but skype refuses to
use the mic that is built into the webcam (as well as pretending that
the usb headset doesn't exist). so it appears that skype is ignorant
of USB audio devices. Not sure why that would be, since such things are
"just another" audio device.

Valeri Galtsev
Sr System Administrator
Department of Astronomy and Astrophysics
Kavli Institute for Cosmological Physics
University of Chicago
Phone: 773-702-4247
CentOS mailing list

Reply via email to