Il 29/06/20 16:02, Phil Perry ha scritto:
On 29/06/2020 07:36, Alessandro Baggi wrote:
Hi list,

I'm on C8.1 and I'm trying to install NVIDIA driver from rpmfusion-nonfree repository but it returns:

  package kmod-nvidia-3:440.82-2.el8.x86_64 requires kmod-nvidia-4.18.0-147.el8.x86_64 >= 3:440.82-2.el8, but none of the providers can be installed
   - conflicting requests
   - nothing provides kernel < 4.18.0-148.el8 needed by

The package is looking for an el8.1 kernel to meet it's dependencies and can not find one. C8.2 has now been released, and as a result all 8.1 packages got moved to vault. If you enable the vault repo, yum will be able to find the kernel package it is looking for to meet the dependencies. However, if you do that you will have to boot to an old C8.1 series kernel for your nvidia drivers to work.

(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

and uname -r returns:


Yes, you are running the latest 8.2 series kernel.

Seems that RPMFusion needs an update. Waiting for this there is a way to install this package without fall in problems?

Thank you in advance.

Yes, seems that repo is stale. They need to release packages built against el8.2, which at least for RHEL have been out for 2 months now. A newer stable nvidia driver (440.100) was also released recently. The (not ideal) workaround is as stated above - enable CentOS vault repo and boot into an older el8.1 series kernel for now until they update packages.

I would normally recommend you try the nvidia drivers from elrepo, but I have a vested interest as I maintain them


Hi Phil,

thank you for your answer.

I tried with this after installing ELrepo repository:

yum --enablerepo=elrepo install kmod-nvidia

but I get the same result for different version.

CentOS mailing list

Reply via email to