On Mon, Feb 19, 2018 at 07:57:18PM -0600, Graham Allan wrote:
> Sorry to send another long followup, but actually... I'm not sure how to 
> change the placement_rule for a bucket - or at least what I tried does 
> not seem to work. Using a different (more disposable) bucket, my attempt 
> went like this::
[snip]

> first created a new placement rule "old-placement" in both the zonegroup 
> and zone commit new period - this looks ok.
...
> I edit "placement_rule": to change "" -> "old-placement" and write it 
> back using:
> 
> > radosgw-admin metadata put bucket.instance:boto-demo-100:default.2170793.10 
> > < boto-demo-100.json
> 
> Now when I run "radosgw-admin bucket list --bucket=boto-demo-100" I am 
> getting an empty list, though I'm pretty sure the bucket contains some 
> objects.
> 
> When I read the bucket instance metadata back again, it still reads 
> "placement_rule": "" so I wonder if the bucket_info change is really 
> taking effect.
So it never showed the new placement_rule if you did a get after the
put?

> A quick debug session seems to show it still querying the wrong pool 
> (100) for the index, so it seems that my attempt to update the 
> bucket_info is either failing or incorrect!
Did you run a local build w/ the linked patch? I think that would have
more effect than 

-- 
Robin Hugh Johnson
Gentoo Linux: Dev, Infra Lead, Foundation Treasurer
E-Mail   : robb...@gentoo.org
GnuPG FP : 11ACBA4F 4778E3F6 E4EDF38E B27B944E 34884E85
GnuPG FP : 7D0B3CEB E9B85B1F 825BCECF EE05E6F6 A48F6136

Attachment: signature.asc
Description: Digital signature

_______________________________________________
ceph-users mailing list
ceph-users@lists.ceph.com
http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com

Reply via email to