I think Barney's really hit the nail squarely on the head (as per usual) :)
If there's a speed difference, it's certainly going to be negligible. Readability is the bigger factor (and since I'm quite certain everyone's dying to know, I prefer <cfset foo = var1 & "123" /> :) On 1/30/06, Munson, Jacob <[EMAIL PROTECTED]> wrote: > Check out the function getTickCount: > http://www.techfeed.net/cfQuickDocs/?gettickcount > and Ben Forta's has a good example: > http://tinyurl.com/9m7vm > > > -----Original Message----- > > From: James Reily [mailto:[EMAIL PROTECTED] > > Sent: Monday, January 30, 2006 11:48 AM > > To: CF-Talk > > Subject: Which string operation is faster? > > > > Which of these executes faster, or do they each take the same > > amount of processing? Are they equivalent "under the hood"? > > > > <cfset foo = "#var1#123"> > > > > or > > > > <cfset foo = var1 & "123"> > > This transmission may contain information that is privileged, confidential > and/or exempt from disclosure under applicable law. If you are not the > intended recipient, you are hereby notified that any disclosure, copying, > distribution, or use of the information contained herein (including any > reliance thereon) is STRICTLY PROHIBITED. If you received this transmission > in error, please immediately contact the sender and destroy the material in > its entirety, whether in electronic or hard copy format. Thank you. A1. > > > > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~| Message: http://www.houseoffusion.com/lists.cfm/link=i:4:230768 Archives: http://www.houseoffusion.com/cf_lists/threads.cfm/4 Subscription: http://www.houseoffusion.com/lists.cfm/link=s:4 Unsubscribe: http://www.houseoffusion.com/cf_lists/unsubscribe.cfm?user=11502.10531.4 Donations & Support: http://www.houseoffusion.com/tiny.cfm/54

