Mike, I append "vw" to views and "inx" to tables. You should NOT append "SP_" to a stored procedure. MSSQL will assume this is a system stored proc and check system tables for it first - before checking user tables. That's additional overhead. I usually use spProcedureName (no underscore). As for tables I try to use a dbname abbrivietion combined with a descriptive table name. For example, if the db is "NewProducts" and I had a table called for inventory, I would probably name it npInventory or np_Inventory. I do not use tbl_ or tb_ because MOST of the objects you work with are tables, so if you specify everything else (inx_ or vw_) then you can think of tb_ as the "default" object. Kind of like scoping all variables EXCEPT the variables scope (which is the first scope assumed).
Mark -----Original Message----- From: Tangorre, Michael [mailto:[EMAIL PROTECTED]] Sent: Monday, July 15, 2002 10:10 AM To: CF-Talk Subject: Slightly OT: DB Object Naming Conventions Does anyone here follow the following naming convention in SQL Server? Tables: tbl_tablename Views: vw_viewname Stored Procedures: sp_procedurename I'm just tyring to get a quick poll as to who might follow this way of naming.. Thanks. You can reply off list to me.. Mike ______________________________________________________________________ Get the mailserver that powers this list at http://www.coolfusion.com FAQ: http://www.thenetprofits.co.uk/coldfusion/faq Archives: http://www.mail-archive.com/[email protected]/ Unsubscribe: http://www.houseoffusion.com/index.cfm?sidebar=lists

