For what it's worth.. I'd always recommend using setVariable(). I'm not convinced it performs slower and unlike the workaround is a documented function that you can be sure will work in subsequent version releases of the product -- oh and it looks a lot more readable to me :)

But each to their own,

-- geoff
http://www.daemon.com.au/

Andrew Muller wrote:

Viktor's method should work and prolly will perform a little better than the SetVariable function.


Viktor Radnai wrote:


I have a feeling that this would work too: "Variable.#VariableforVariablename#" = 1;

I can't test it right now but give it a go...


Mark M wrote:


*SetVariable*(/name/, /value/)


Straight outta the docs.



Mark


[EMAIL PROTECTED] <mailto:[EMAIL PROTECTED]>

ICQ: 3094740


-----Original Message-----
*From:* [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] *On Behalf Of *Taco Fleur
*Sent:* Sunday, 23 February 2003 12:08 PM
*To:* CFAussie Mailing List
*Subject:* [cfaussie] Dynamically naming vars in cfscript?




Is it possible to dynamically name variables in cfscript? if so, how?

---
You are currently subscribed to cfaussie as: [EMAIL PROTECTED]
To unsubscribe send a blank email to [EMAIL PROTECTED]

MX Downunder AsiaPac DevCon - http://mxdu.com/




---
You are currently subscribed to cfaussie as: [EMAIL PROTECTED]
To unsubscribe send a blank email to [EMAIL PROTECTED]

MX Downunder AsiaPac DevCon - http://mxdu.com/

Reply via email to