On Jul 27, 2011, at 11:20 AM, Argyrios Kyrtzidis wrote: > > On Jul 27, 2011, at 11:11 AM, Chris Lattner wrote: > >> >> On Jul 27, 2011, at 10:57 AM, David Blaikie wrote: >> >>>> Please capitalize local variable names. >>> >>> Hmm - I've seen some inconsistency in that regard in the existing code >>> & I tried to find something in the LLVM coding conventions ( >>> http://llvm.org/docs/CodingStandards.html#ll_naming ) but it didn't >>> seem to cover variable names at all. Is that the rule, then, variable >>> names follow the type name rules (ThingType, ThingVariable, >>> thingFunction)? >> >> Yes, that's the style I would prefer. > > Could we start a bikeshed discussion and add the consensus to the coding > standard ? IMO it provides value to have local variables lower-case so they > are easily separated from member variables. > Also a bikeshed discussion for parameters.
I'm not a big fan of hungarian notation (aka, mangling properties of a variable into the name). -Chris _______________________________________________ cfe-commits mailing list [email protected] http://lists.cs.uiuc.edu/mailman/listinfo/cfe-commits
